-   Linux - Server (
-   -   Subversion Version issue (

mdfakkeer 10-13-2010 04:14 AM

Subversion Version issue
1 Attachment(s)
I compiled and installed subversion 1.4.3 on ubuntu 9.10. After installing , I checked the svn version through the svnadmin –version command . It shows like below

hadoopadmin@DcpSlave1:/etc/apache2/sites-available$ svnadmin --version
svnadmin, version 1.4.3 (r23084)
compiled Oct 13 2010, 11:12:51

Copyright (C) 2000-2006 CollabNet.
Subversion is open source software, see
This product includes software developed by CollabNet (http://www.Collab.Net/).

The following repository back-end (FS) modules are available:

* fs_fs : Module for working with a plain file (FSFS) repository.

But when I am creating a dummy repo using the svnadmin create command . it create the repo structure as svn 1.6.5 . Also I checked through browser It shows subversion version 1.6.5. Also I tried to copy the our subversion 1.4.3 version server backup content on the server, it through the Human error.

why the version showing 1.6.5 on browser? Any body have idea about solve the issue.?.

bathory 10-13-2010 05:04 AM


I guess your apache still uses the 1.6.5 mod_dav_svn modules.
You can use your distro's package manager to uninstall subversion and libapache2-svn and then use your compiled modules.


mdfakkeer 10-13-2010 06:06 AM

I removed the Libapache2-svn package. Tried to restart apache. apache through error regarding DAV. How to solve the issue?. Any alternete package for subversion 1.4.3 and apache to work.

bathory 10-13-2010 06:31 AM

You should post the exact error you get.

Anyway, ubuntu uses a2enmod to enable apache modules installed with apt-get. you can do it by hand, by copying the dav.svn modules into /usr/lib/apache2/modules and make sure your have a file /etc/apache2/mods-enabled/dav_svn.conf containing:

LoadModule dav_module modules/
LoadModule dav_svn_module modules/

BTW, why do you want to downgrade subversion?

mdfakkeer 10-14-2010 01:39 AM

I am using subversion 1.4.3.I want to migrate all my repo data to one server(running fedora 6 subversion 1.4.3) to another server( running ubuntu 10.04 subversion 1.6.5). i used the dump command to create one dump file. dump file size is 27 GB. After moving dump file to new server, i used the load command to retrieve the data and revision to new server.

after committed the revision 30933 it stops the process and through the following error.

svadmin can't increment mergeinfo count on node revision 0.298.0.t30933-nv9 to negative value -62276514519093008422
* adding path : labels/ ....

I skip the particular revision through the following method

svnadmin dump -r 1:30932 > mycode.dump
svnadmin dump -r 30934:HEAD >> mycode.dump

svnadmin load /this/is/my/new/path < mycode.dump

But so many revision has same problem.

my repo conatain 50234 revision. How to copy all my revision to my new server. So now tried with subversion 1.4.3 with hotcopy on new server.If any body knows how to migrate all my repo in 1.4.3 to 1.6.5. please reply.

prayag_pjs 10-14-2010 08:30 AM

Can you do


which svn
and also


rpm -qf `which svn`

All times are GMT -5. The time now is 06:58 AM.