LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 02-04-2010, 03:45 AM   #1
skylimit123
LQ Newbie
 
Registered: Nov 2008
Posts: 21

Rep: Reputation: 15
Strange DNS problem or ... ?


Hello all,

This is configuration I have:
Server A is DNS server which has dns entries (beside other entries) for server B like this:

nameB.domain.com. A 1.2.3.4
forum CNAME nameB.domain.com.
test1 CNAME nameB.domain.com.


On Server B I'm running Apache with virtual hosts for "forum" and "test1". forum.domain.com goes to /home/forum and test1.domain.com goes to /home/test1.

Here is the problem. Forum is not working on every computer that is trying to access it around the world. Because everything is working like it should from my computer I have tried to access forum from some public proxy. The weird thing is that it is working from time to time, not always.
Tcpdump says that connection is not even reaching server on port 80 when that proxy is trying to open forum.
I must say that test1.domain.com is working always. Also when I move forum domain in Virtual Host to load from /home/test1 it is not working either.


Where can be problem that some of users can reach forum and some of them not?

Tnx in advance
 
Old 02-04-2010, 05:41 AM   #2
Dave_Devnull
Member
 
Registered: May 2009
Posts: 142

Rep: Reputation: 24
Do you have any other authoritative name servers?

if you run 'dig @8.8.8.8 forum.domain.com' (assuming you have dig, if not: nslookup -querytype=A forum.domain.com 8.8.8.8
) do the google public DNS servers resolve forum.domain.com OK?
 
Old 02-05-2010, 06:09 AM   #3
skylimit123
LQ Newbie
 
Registered: Nov 2008
Posts: 21

Original Poster
Rep: Reputation: 15
Dave, thank you.
I found where the problem was. Serials were not the same on the master and slave servers, so slave servers didn't receive updates. Everything is working now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
strange DNS problem? cyrwyn Linux - Networking 4 06-22-2007 11:29 AM
Strange DNS problem ~=gr3p=~ Linux - Networking 1 12-23-2005 11:29 PM
Strange DNS problem JonCooperUK Slackware 3 04-02-2004 12:09 PM
Strange dns problem jekyl Linux - Networking 1 01-15-2003 12:49 PM
strange firewall/DNS problem marsonist Linux - Networking 8 01-03-2003 01:41 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 03:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration