View the Most Wanted LQ Wiki articles.
Go Back > Forums > Linux Forums > Linux - Server
User Name
Linux - Server This forum is for the discussion of Linux Software used in a server related context.


  Search this Thread
Old 04-02-2007, 07:06 AM   #1
LQ Newbie
Registered: Apr 2007
Posts: 1

Rep: Reputation: 0
Talking STARTTLS server: SSL routines: SSL23_GET_CLIENT_HELLO: unknown protocol: s23_srvr.c:5

The situation is:

SuSE 10.2 server with sendmail (8.13), MailScanner (with f-prot, clamav and bitdefender antivirus) and Spamassassin, for IMAPs and POP3s i use the default services under xinetd (I used dovecot but had troubles setting up IMAPs and POP3s so I removed it)

I am trying to secure my mail traffic. I implemented successfully POP3s. Now i'm trying to implement SMTP AUTH + TLS. I've compiled sendmail as a TLS server, when i run "telnet localhost 25" and give it an "ehlo" i can see that TLS is available, also AUTH. I am not convinced, so I check again with "sendmail -d0.1 -bv root" and I can see there "SASLv2" So, I am getting excited and I try "starttls" after telnet on localhost. My beauty responds with an " 2.0.0 ready to start tls". I am already happy and i try talking with her : "ehlo localhost" And there she goes... conection is closed without warnings.
I am trying to understand what's happening and give it a try with "sendmail -O LogLevel=14 -bs -Am" and after look into the mail log and here is what I get:

Apr 2 14:52:11 suse sendmail[23845]: NOQUEUE: connect from root@localhost
Apr 2 14:52:11 suse sendmail[23845]: STARTTLS=server, Diffie-Hellman init, key=512 bit (1)
Apr 2 14:52:11 suse sendmail[23845]: STARTTLS=server, init=1
Apr 2 14:52:11 suse sendmail[23845]: AUTH: available mech=CRAM-MD5 DIGEST-MD5 PLAIN LOGIN ANONYMOUS GSSAPI, allowed mech=PLAIN LOGIN GSSAPI
Apr 2 14:52:11 suse sendmail[23845]: l32BqB24023845: Milter: no active filter
Apr 2 14:52:40 suse sendmail[23845]: STARTTLS=server, error: accept failed=-1, SSL_error=1, errno=0, retry=-1
Apr 2 14:52:40 suse sendmail[23845]: STARTTLS=server: 23845:error:140760FC:SSL routines:SSL23_GET_CLIENT_HELLO:unknown protocol:s23_srvr.c:562:
Apr 2 14:52:40 suse sendmail[23845]: l32BqB24023845: root@localhost did not issue MAIL/EXPN/VRFY/ETRN during connection to stdin

I am not a linux guru, i am a little bit more than a newbie. Can someone help ? pls pls pls

Last edited by bennyhll; 04-02-2007 at 07:15 AM.
Old 04-02-2007, 07:16 AM   #2
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1971Reputation: 1971Reputation: 1971Reputation: 1971Reputation: 1971Reputation: 1971Reputation: 1971Reputation: 1971Reputation: 1971Reputation: 1971Reputation: 1971
clearly NOT a members intro. moved to Linux - Server.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
IDE Routines ashlesha Linux - Software 0 08-09-2006 12:29 PM
ARP routines.... shrishailnk Linux - Networking 2 04-29-2006 11:21 AM
Unknown protocol 'audiocd' kvnband Linux - Software 3 12-28-2005 01:49 PM
keyboard routines using ncurses deveraux83 Programming 0 03-02-2005 06:41 PM
Sendmail STARTTLS Manuel-H Linux - General 0 04-11-2003 08:20 AM

All times are GMT -5. The time now is 01:59 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration