LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 02-05-2018, 03:09 AM   #1
mkomid
LQ Newbie
 
Registered: Feb 2018
Posts: 5

Rep: Reputation: Disabled
starting MariaDB 10.1.30 in CentOS 7 server


Hi, I have installed MariaDB 10.1.30 in my CentOS 7 server ,but when i try to start it I get the following message :Job for mariadb.service failed because the control process exited with error code. See "systemctl status mariadb.service" and "journalctl -xe" for details.
Please help me . Thanks a lot in advance .
 
Old 02-05-2018, 11:24 AM   #2
Emerson
LQ Guru
 
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 6,317

Rep: Reputation: Disabled
Quote:
Originally Posted by mkomid View Post
Hi, I have installed MariaDB 10.1.30 in my CentOS 7 server ,but when i try to start it I get the following message :Job for mariadb.service failed because the control process exited with error code. See "systemctl status mariadb.service" and "journalctl -xe" for details.
Please help me . Thanks a lot in advance .
Do I understand correctly you want someone to come and run these commands for you? Are you willing to pay the travel expenses?
 
Old 02-06-2018, 06:29 AM   #3
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,739

Rep: Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838
Quote:
Originally Posted by mkomid View Post
Hi, I have installed MariaDB 10.1.30 in my CentOS 7 server ,but when i try to start it I get the following message :Job for mariadb.service failed because the control process exited with error code. See "systemctl status mariadb.service" and "journalctl -xe" for details.
Please help me . Thanks a lot in advance .
Did you follow the instructions given with the error message?
Run the 2 commands suggested:
Code:
systemctl status mariadb.service
journalctl -xe
and post here the results.
 
Old 02-07-2018, 05:03 AM   #4
mkomid
LQ Newbie
 
Registered: Feb 2018
Posts: 5

Original Poster
Rep: Reputation: Disabled
Hi bathory , as you asked I did

[root@iseco kazem]# systemctl status mariadb.service
● mariadb.service - MariaDB 10.1.30 database server
Loaded: loaded (/usr/lib/systemd/system/mariadb.service; enabled; vendor pres et: disabled)
Drop-In: /etc/systemd/system/mariadb.service.d
└─migrated-from-my.cnf-settings.conf
Active: failed (Result: exit-code) since Mon 2018-02-05 09:00:49 UTC; 2 days ago
Docs: man:mysqld(8)
https://mariadb.com/kb/en/library/systemd/
Process: 17687 ExecStart=/usr/sbin/mysqld $MYSQLD_OPTS $_WSREP_NEW_CLUSTER $_W SREP_START_POSITION (code=exited, status=1/FAILURE)
Process: 17675 ExecStartPre=/bin/sh -c [ ! -e /usr/bin/galera_recovery ] && VA R= || VAR=`/usr/bin/galera_recovery`; [ $? -eq 0 ] && systemctl set-environm ent _WSREP_START_POSITION=$VAR || exit 1 (code=exited, status=0/SUCCESS)
Process: 17672 ExecStartPre=/bin/sh -c systemctl unset-environment _WSREP_STAR T_POSITION (code=exited, status=0/SUCCESS)
Main PID: 17687 (code=exited, status=1/FAILURE)
Status: "MariaDB server is down"

Feb 05 09:00:46 iseco.iransand.com mysqld[17687]: 2018-02-05 9:00:46 1404459...
Feb 05 09:00:46 iseco.iransand.com mysqld[17687]: 2018-02-05 9:00:46 1404452...
Feb 05 09:00:46 iseco.iransand.com mysqld[17687]: 2018-02-05 9:00:46 1404459...
Feb 05 09:00:46 iseco.iransand.com mysqld[17687]: 2018-02-05 9:00:46 1404459...
Feb 05 09:00:46 iseco.iransand.com mysqld[17687]: 2018-02-05 9:00:46 1404459...
Feb 05 09:00:46 iseco.iransand.com mysqld[17687]: 2018-02-05 9:00:46 1404459...
Feb 05 09:00:49 iseco.iransand.com systemd[1]: mariadb.service: main process...E
Feb 05 09:00:49 iseco.iransand.com systemd[1]: Failed to start MariaDB 10.1.....
Feb 05 09:00:49 iseco.iransand.com systemd[1]: Unit mariadb.service entered ....
Feb 05 09:00:49 iseco.iransand.com systemd[1]: mariadb.service failed.
Hint: Some lines were ellipsized, use -l to show in full.


[root@iseco kazem]# systemctl start mariadb.service
Job for mariadb.service failed because the control process exited with error code. See "systemctl status mariadb.service" and "journalctl -xe" for details.


[root@iseco kazem]# journalctl -xe
Feb 07 10:42:45 iseco.iransand.com mysqld[24074]: 2018-02-07 10:42:45 140085072853248
Feb 07 10:42:48 iseco.iransand.com mysqld[24074]: 2018-02-07 10:42:48 140085072853248
Feb 07 10:42:49 iseco.iransand.com mysqld[24074]: 2018-02-07 10:42:49 140085072853248
Feb 07 10:42:49 iseco.iransand.com mysqld[24074]: 2018-02-07 10:42:49 140085072853248
Feb 07 10:42:49 iseco.iransand.com mysqld[24074]: 2018-02-07 10:42:49 140085072853248
Feb 07 10:42:49 iseco.iransand.com mysqld[24074]: 2018-02-07 10:42:49 140085072853248
Feb 07 10:42:49 iseco.iransand.com mysqld[24074]: 2018-02-07 10:42:49 140084330325760
Feb 07 10:42:49 iseco.iransand.com mysqld[24074]: 2018-02-07 10:42:49 140085072853248
Feb 07 10:42:49 iseco.iransand.com mysqld[24074]: 2018-02-07 10:42:49 140085072853248
Feb 07 10:42:49 iseco.iransand.com mysqld[24074]: 2018-02-07 10:42:49 140085072853248
Feb 07 10:42:49 iseco.iransand.com mysqld[24074]: 2018-02-07 10:42:49 140085072853248
Feb 07 10:42:51 iseco.iransand.com systemd[1]: mariadb.service: main process exited,
Feb 07 10:42:51 iseco.iransand.com systemd[1]: Failed to start MariaDB 10.1.30 databa
-- Subject: Unit mariadb.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman.../systemd-devel
--
-- Unit mariadb.service has failed.
--
-- The result is failed.
Feb 07 10:42:51 iseco.iransand.com systemd[1]: Unit mariadb.service entered failed st
Feb 07 10:42:51 iseco.iransand.com systemd[1]: mariadb.service failed.
Feb 07 10:42:51 iseco.iransand.com polkitd[351]: Unregistered Authentication Agent fo
 
Old 02-07-2018, 07:45 AM   #5
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,739

Rep: Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838
Quote:
Hint: Some lines were ellipsized, use -l to show in full.
Again, follow the hint and run:
Code:
systemctl -l status mariadb.service

You can also take a look at mariadb logs located usually under /var/log/mariadb
 
Old 02-13-2018, 04:55 AM   #6
mkomid
LQ Newbie
 
Registered: Feb 2018
Posts: 5

Original Poster
Rep: Reputation: Disabled
[root@iseco ~]# systemctl -l status mariadb.service
● mariadb.service - MariaDB 10.1.30 database server
Loaded: loaded (/usr/lib/systemd/system/mariadb.service; enabled; vendor preset: disabled)
Drop-In: /etc/systemd/system/mariadb.service.d
└─migrated-from-my.cnf-settings.conf
Active: failed (Result: exit-code) since Tue 2018-02-13 10:49:16 UTC; 43s ago
Docs: man:mysqld(8)
https://mariadb.com/kb/en/library/systemd/
Process: 20604 ExecStart=/usr/sbin/mysqld $MYSQLD_OPTS $_WSREP_NEW_CLUSTER $_WSREP_START_POSITION (code=exited , status=1/FAILURE)
Process: 20592 ExecStartPre=/bin/sh -c [ ! -e /usr/bin/galera_recovery ] && VAR= || VAR=`/usr/bin/galera_rec overy`; [ $? -eq 0 ] && systemctl set-environment _WSREP_START_POSITION=$VAR || exit 1 (code=exited, status=0/ SUCCESS)
Process: 20589 ExecStartPre=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status= 0/SUCCESS)
Main PID: 20604 (code=exited, status=1/FAILURE)
Status: "MariaDB server is down"

Feb 13 10:49:14 iseco.iransand.com mysqld[20604]: 2018-02-13 10:49:14 140582670436608 [Note] Plugin 'FEEDBACK' i s disabled.
Feb 13 10:49:14 iseco.iransand.com mysqld[20604]: 2018-02-13 10:49:14 140581925775104 [Note] InnoDB: Dumping buf fer pool(s) not yet started
Feb 13 10:49:14 iseco.iransand.com mysqld[20604]: 2018-02-13 10:49:14 140582670436608 [Note] Server socket creat ed on IP: '::'.
Feb 13 10:49:14 iseco.iransand.com mysqld[20604]: 2018-02-13 10:49:14 140582670436608 [ERROR] Can't start server : Bind on TCP/IP port. Got error: 98: Address already in use
Feb 13 10:49:14 iseco.iransand.com mysqld[20604]: 2018-02-13 10:49:14 140582670436608 [ERROR] Do you already hav e another mysqld server running on port: 3306 ?
Feb 13 10:49:14 iseco.iransand.com mysqld[20604]: 2018-02-13 10:49:14 140582670436608 [ERROR] Aborting
Feb 13 10:49:16 iseco.iransand.com systemd[1]: mariadb.service: main process exited, code=exited, status=1/FAILU RE
Feb 13 10:49:16 iseco.iransand.com systemd[1]: Failed to start MariaDB 10.1.30 database server.
Feb 13 10:49:16 iseco.iransand.com systemd[1]: Unit mariadb.service entered failed state.
Feb 13 10:49:16 iseco.iransand.com systemd[1]: mariadb.service failed.
 
Old 02-13-2018, 05:56 AM   #7
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,739

Rep: Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838
Quote:
Feb 13 10:49:14 iseco.iransand.com mysqld[20604]: 2018-02-13 10:49:14 140582670436608 [ERROR] Can't start server : Bind on TCP/IP port. Got error: 98: Address already in use
Feb 13 10:49:14 iseco.iransand.com mysqld[20604]: 2018-02-13 10:49:14 140582670436608 [ERROR] Do you already hav e another mysqld server running on port: 3306 ?
Why don't you follow the log hints?
Most likely you have another mariadb/mysql instance already running? Check with:
Code:
netstat -tanpl|grep 3306
 
Old 02-14-2018, 12:33 AM   #8
Hostech_Support
Member
 
Registered: Oct 2017
Location: India
Posts: 41

Rep: Reputation: Disabled
Quote:
Originally Posted by mkomid View Post
Hi, I have installed MariaDB 10.1.30 in my CentOS 7 server ,but when i try to start it I get the following message :Job for mariadb.service failed because the control process exited with error code. See "systemctl status mariadb.service" and "journalctl -xe" for details.
Please help me . Thanks a lot in advance .
>> Did you get any error while installing MariaDB? not sure but seems MariaDB is not installed completely on the Server in case of Partial installations such errors occur.
 
Old 02-14-2018, 08:56 AM   #9
mkomid
LQ Newbie
 
Registered: Feb 2018
Posts: 5

Original Poster
Rep: Reputation: Disabled
[root@iseco ~]# netstat -tanpl|grep 3306
tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN 13735/mysqld


By the way i didn't get any error during installation of MariaDB .
 
Old 02-14-2018, 11:52 AM   #10
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,739

Rep: Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838
Quote:
Originally Posted by mkomid View Post
[root@iseco ~]# netstat -tanpl|grep 3306
tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN 13735/mysqld


By the way i didn't get any error during installation of MariaDB .
So it's up and running!
You didn't get any errors, because it was installed and started successfully.
 
Old 02-17-2018, 04:09 AM   #11
mkomid
LQ Newbie
 
Registered: Feb 2018
Posts: 5

Original Poster
Rep: Reputation: Disabled
But still i get the same message as shown below :

[root@iseco ~]# systemctl start mariadb.service
Job for mariadb.service failed because the control process exited with error code. See "systemctl status mariadb.service" and "journalctl -xe" for details.

I deeply appreciate your sincere consideration and assistance . Thank you so much .
 
Old 02-17-2018, 07:54 AM   #12
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,739

Rep: Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838
Quote:
Originally Posted by mkomid View Post
But still i get the same message as shown below :

[root@iseco ~]# systemctl start mariadb.service
Job for mariadb.service failed because the control process exited with error code. See "systemctl status mariadb.service" and "journalctl -xe" for details.

I deeply appreciate your sincere consideration and assistance . Thank you so much .
It's still running.
Stop it first and then start it again. Or just do a restart and see what happens.
 
Old 02-17-2018, 04:38 PM   #13
scasey
LQ Veteran
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.8.2003
Posts: 5,152

Rep: Reputation: 1878Reputation: 1878Reputation: 1878Reputation: 1878Reputation: 1878Reputation: 1878Reputation: 1878Reputation: 1878Reputation: 1878Reputation: 1878Reputation: 1878
Is mysqld the same as mariadb? I'm guessing not, because on my centos 7 system I'm running mysql and I have no mariadb service running.
Both would run on port 3306.

OP: I think you have an installed and running mysql and that's why you can't start mariadb. If you want to change from mysql to mariadb try:
Code:
systemctl stop mysqld.service
systemctl start mariadb.service
Check each with
Code:
systemctl status mysqld.service
systemctl status mariadb.service
before and after each command.

Let us know what happens, please.

Last edited by scasey; 02-17-2018 at 04:40 PM.
 
Old 02-17-2018, 05:48 PM   #14
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,739

Rep: Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838Reputation: 1838
Quote:
Originally Posted by scasey View Post
Is mysqld the same as mariadb? I'm guessing not, because on my centos 7 system I'm running mysql and I have no mariadb service running.
Both would run on port 3306.
Centos 7 comes with MariaDB as the default database server.
AFAIK if you still want to install mysql, you have to use a third party repository.


@OP
Since MariaDB daemon is also named mysqld, we cannot tell for sure which one is running, but you can use the package manager to find out the one installed.
 
Old 02-17-2018, 08:26 PM   #15
scasey
LQ Veteran
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.8.2003
Posts: 5,152

Rep: Reputation: 1878Reputation: 1878Reputation: 1878Reputation: 1878Reputation: 1878Reputation: 1878Reputation: 1878Reputation: 1878Reputation: 1878Reputation: 1878Reputation: 1878
bathory,
I did not know that about the mariadb daemon. When I built my centos 7 server, I found and installed the "mysql-community" version of mysqld...and yes, that's from another repository: mysql57-community.
I was concerned about breaking the customer's applications that were using mysqld...

I agree with you that the OP should try a restart of the mariadb service.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Set up a mail server with PostfixAdmin and MariaDB on CentOS 7 LXer Syndicated Linux News 0 05-12-2017 12:42 PM
[SOLVED] CentOS 7 - Problems with firewalld/iptables on CentOS 7 Router -Can't connect to MariaDB between private networks (Virtual Box) arkfantasy CentOS 4 01-09-2017 01:56 PM
LXer: FTP server with PureFTPd and MariaDB virtual users (incl. Quota and Bandwidth Management) on CentOS 7.2 LXer Syndicated Linux News 0 07-04-2016 02:04 PM
MariaDB Galera Cluster Starting Issue blakk Red Hat 2 03-05-2015 02:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 09:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration