-   Linux - Server (
-   -   SSL won't start on Debian (

dbsput 05-17-2011 06:13 AM

SSL won't start on Debian
Hi guys,

Hopefully someone can help.

I have Apache running fine on a webserver but now just tried to get SSL running also. I made a copy of default-ssl and changed the SSLCertificateKeyFile record to match the certificate I had. I enabled the site through a2enmod and restarted apache but a telnet to 443 tells me that SSL is not running. Also apache2ctl -S is not listing the record. There is no indication in the errors logs to give me a clue.

Does anyone have some suggestions to what I can look for?

EricTRA 05-17-2011 06:48 AM


Did you enable the SSL module with

a2enmod ssl
and enable the site with

a2ensite yoursite

What's in your default-ssl configuration file?

Kind regards,


dbsput 05-17-2011 09:50 PM

Thanks EricTRA,

I have forgotten that the SSL module had to be enabled.

EricTRA 05-18-2011 02:05 AM


You're welcome. If you consider your problem solved then please mark this thread as such. Have fun with Linux.

Kind regards,


All times are GMT -5. The time now is 02:37 PM.