Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Server
User Name
Linux - Server This forum is for the discussion of Linux Software used in a server related context.


  Search this Thread
Old 10-25-2013, 06:43 AM   #1
Joe of Loath
Registered: Dec 2009
Location: Bristol, UK
Distribution: Ubuntu, Debian, Arch.
Posts: 152

Rep: Reputation: 28
SSL on Lighttpd - 404 errors

Hey there

Just installed an SSL certificate on my Lighttpd server (Going to install a wiki for a project I'm working on). The certificate works fine, and I can connect with a secured connection to https://*localIP*. However, all I get is a 404 error.


server.modules = (
#       "mod_rewrite",

server.document-root        = "/data"
server.upload-dirs          = ( "/var/cache/lighttpd/uploads" )
server.errorlog             = "/var/log/lighttpd/error.log"             = "/var/run/"
server.username             = "www-data"
server.groupname            = "www-data"

index-file.names            = ( "index.php", "index.html",
                                "index.htm", "default.htm",
                               " index.lighttpd.html" )

url.access-deny             = ( "~", ".inc" )

static-file.exclude-extensions = ( ".php", ".pl", ".fcgi" )

## Use ipv6 if available
#include_shell "/usr/share/lighttpd/"

dir-listing.encoding        = "utf-8"
server.dir-listing          = "enable"

compress.cache-dir          = "/var/cache/lighttpd/compress/"
compress.filetype           = ( "application/x-javascript", "text/css", "text/html", "text/plain" )

include_shell "/usr/share/lighttpd/"
include_shell "/usr/share/lighttpd/"

$SERVER["socket"] == "xx.xx.xx.xx:443" {
server.document-root = "/home/lighttpd/"
ssl.engine = "enable"
ssl.pemfile = "/etc/lighttpd/ssl/" = ""
##server.document-root = "/data/"
I assumed it was a document root issue, so I set it but it complained about duplication.

Pretty sure I've done something stupid but I'm not totally sure what (obviously).

Old 10-25-2013, 02:39 PM   #2
Joe of Loath
Registered: Dec 2009
Location: Bristol, UK
Distribution: Ubuntu, Debian, Arch.
Posts: 152

Original Poster
Rep: Reputation: 28
OK, just realised I'm an idiot. Config file I copypasta'd from had a document root setting alreadt in it.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
mod_jk doesn't handle 404 errors correctly petestorey Linux - Server 2 10-15-2012 03:58 AM
Script Kiddies and 403, 404 errors baldur2630 Linux - Security 2 01-08-2012 05:33 PM
[SOLVED] Apache Don't Log 404 Errors fukawi2 Linux - Server 3 02-17-2010 12:04 AM
lighttpd + ssl: can't seem to update my server-side certificates Kropotkin Linux - Security 4 09-19-2009 07:32 AM
trailing slash in Apache gives 404 errors rabbate Linux - General 6 04-30-2004 08:34 AM > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 07:26 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration