LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 03-27-2008, 08:26 PM   #1
ieduarte73
Member
 
Registered: Aug 2005
Location: Guatemala
Distribution: OpenSUSE 10.3 / FC 8 / Ubuntu 7.10 (Gutsy Gibbon)
Posts: 34

Rep: Reputation: 15
SSL Error 12263 on OpenSUSE 10.2 running Apache 2, and OpenSSL 0.9.8d


I have an OpenSuse 10.2 Server, and I am doing some e-commerce test in that server, but after I configured Apache 2 to use SSL, and restarted it using: startssl parameter, I get an error when I try to reach the website:

Error -12263

I have checked my config files and they contain a line:

SSLEngine On

What can be causing this problem?
 
Old 03-30-2008, 08:16 AM   #2
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,991

Rep: Reputation: 76
Hi. I can't post a solution yet, because I'm experiencing the same problem.
But this seems to be similar to the problem you are having; perhaps it may help:
http://www.dotmana.com/index.php/?p=352

Edit: I've just noticed that, on my configuration, if I go to http://server:443 (rather than using https), I get the page I was expecting.

I wonder if this error code is perhaps Firefox's way of saying that it got an HTTP server on a port where it expected to be able to use HTTPS (i.e. an ordinary server not a secure one)?

Last edited by rjlee; 03-30-2008 at 08:25 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache running very slowly on OpenSuSE 10.2 kaplan71 SUSE / openSUSE 0 07-19-2007 12:10 PM
HTTPS returns error code -12263 mesh2005 Linux - Server 3 07-10-2007 11:52 AM
Running Apache 2.x on OpenSUSE 10.2 Dee-ehn SUSE / openSUSE 3 04-24-2007 06:51 AM
apache 2.0.55 & openssl 0.9.8 error? ziggie216 Linux - Software 4 11-27-2005 08:37 PM
Apache + SSL + Upgrading OpenSSL shared lib TruckStuff Linux - Security 2 07-06-2005 05:41 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 06:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration