-   Linux - Server (
-   -   SSH Problem (

kohshan99 12-29-2012 12:11 AM

SSH Problem
hi Friends,

when i login any server using SSH. but after some mints a Killed command appear and link is broken...

what is the problem??

im using x86 Ubuntu

bathory 12-29-2012 04:46 AM


Have a look here


kohshan99 12-30-2012 01:10 AM

thanks for reply.. but i do the same thing... still getting Killed command and ssh link disconnect.... here' my ssh conf

# Package generated configuration file
# See the sshd_config(5) manpage for details

# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
HostKey /etc/ssh/ssh_host_ecdsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile %h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
#PasswordAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
ClientAliveInterval 300
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

Subsystem sftp /usr/lib/openssh/sftp-server

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication. Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes

btmiller 12-30-2012 04:39 AM

Try decreasing the ClientAliveInterval to 60 or 120. I've noticed some finicky routers/firewalls will kill idle connections after much less than 5 minutes. Alsom have you tried setting ServerAliveInterval on the client side as well, as specified in the link provided by Bathory?

kohshan99 12-30-2012 11:42 AM

i did every thing but still not succeed.... even i reinstall ssh

alieblice 12-30-2012 01:57 PM

did you run it with 2 or 3 "v" which make it in more debug. you may find good information from it.
ssh -vv USER@IP

bathory 12-30-2012 05:09 PM


Originally Posted by kohshan99 (Post 4859552)
i did every thing but still not succeed.... even i reinstall ssh

What client are you using?
For putty have a look here


kohshan99 12-31-2012 12:18 AM

im usnig ubuntu 12.04 x86 Terminal....

bathory 12-31-2012 03:48 AM


Originally Posted by kohshan99 (Post 4859827)
im usnig ubuntu 12.04 x86 Terminal....

In that case try the 2nd option from my link above. I.e. edit/create a ~/.ssh/config file and use

Host * ServerAliveInterval 300

btmiller 12-31-2012 05:54 PM

Also you should tell us if the client is on the same LAN segment as the server, or if they are on different LANs with a router in between them.

All times are GMT -5. The time now is 06:04 PM.