LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 05-05-2007, 02:01 PM   #1
bennythepitbull
Member
 
Registered: Oct 2003
Distribution: slackware
Posts: 70

Rep: Reputation: 15
ssh for newbe


I am running slackware 11.0 I can not seem to connect to SSH when I attempt to connect to it by the means of using the ip addres assigned to me by verizon:
Here is the error I am getting:

root@LINDOWS:~# ssh 71.161.125.135 -l root
ssh: connect to host 71.161.125.135 port 22: Connection refused
root@LINDOWS:~#

37w versa link is the device verizon gave me. It is an all in one wirless router with 4 laN ports for eth0 - -
I am running hard wired not wirless --
In kde I lok at the runing processes and I see that sshd is running (it has a little ghost icon.)
I did nothing to the config scrips they are set as default would set them in slackware 11.0.

When I run this command I can connect:
ssh 192.168.1.47 -l root

That is all I know so far:

Any takers on where I should go from here?
 
Old 05-05-2007, 02:10 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980
you're trying to presumably ssh to the router, not the computers behind it... http://portforward.com
 
Old 05-05-2007, 02:13 PM   #3
bennythepitbull
Member
 
Registered: Oct 2003
Distribution: slackware
Posts: 70

Original Poster
Rep: Reputation: 15
should have mentioned this

I did config the router to allow 22 and it points to 192.168.1.47
Is this what you mean:
to explain furhter:
The router has a section to allow a service It has a drop down menu that does have SSH and it knows it is on port 22. so I add this service I then tell it to direct the service to IP address 192.168.1.47 .

I am new at this so any more help would be great.
 
Old 05-05-2007, 02:19 PM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980
ok well often routesr also have to have firewall exceptions added for those ports too, is that the case for you? if not, run "tcpdump -vn port 22" on the ssh server and try to connect to it. if you see SYN packets appearing in the tcpdump output, your router has done it's job. if not, it hasn't.
 
Old 05-05-2007, 02:25 PM   #5
bennythepitbull
Member
 
Registered: Oct 2003
Distribution: slackware
Posts: 70

Original Poster
Rep: Reputation: 15
should have mentioned that too

The router has a firewall tab:
I checked disable .

Any other ideas --


It seems like it should just work but it hates me, I think!


Could it be Verizon?
 
Old 05-05-2007, 02:37 PM   #6
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980
i have already given you other ideas with tcpdump.
 
Old 05-06-2007, 10:29 AM   #7
bennythepitbull
Member
 
Registered: Oct 2003
Distribution: slackware
Posts: 70

Original Poster
Rep: Reputation: 15
still will not let me here are my results

root@LINDOWS:~# tcpdump -vn port 22
tcpdump: listening on eth0, link-type EN10MB (Ethernet), capture size 96 bytes

0 packets captured
0 packets received by filter
0 packets dropped by kernel
root@LINDOWS:~#
 
Old 05-06-2007, 10:49 AM   #8
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980
right, so with no packets seen, the router can't be correctly forwarding the data.
 
Old 05-07-2007, 08:49 AM   #9
bennythepitbull
Member
 
Registered: Oct 2003
Distribution: slackware
Posts: 70

Original Poster
Rep: Reputation: 15
it takes forever and a day but...

I left the dump running for like an hour then here is what I get :
IF I leave it run for say 5 minutes UI get all zero's



157 packets captured
314 packets received by filter
0 packets dropped by kernel


Yet when I ssh to my IP address I get connection refused --
 
Old 05-07-2007, 08:56 AM   #10
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980
well it's who those other connections are ... possibly just you connecting on the lan? if they don't appear instantly, they didn't exist.
 
Old 05-08-2007, 07:12 PM   #11
bennythepitbull
Member
 
Registered: Oct 2003
Distribution: slackware
Posts: 70

Original Poster
Rep: Reputation: 15
all set thanks Chris you were most helpful

It seems as if I can only log in away from home I think this is a verizon thing
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbe asking for help!! SeeSor Linux - Newbie 2 03-05-2005 02:36 AM
Please help and NewBe niccotheman Mandriva 3 09-15-2004 08:55 PM
Help For A New New New Newbe blu_la Linux - Newbie 4 02-15-2004 12:15 AM
Hi Another newbe Here splatoid Linux - Software 6 06-13-2003 12:56 AM
Newbe rhotaling1 Linux - General 0 12-02-2002 07:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 06:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration