LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 06-04-2007, 11:09 AM   #1
Ratty_UK
LQ Newbie
 
Registered: Apr 2007
Posts: 7

Rep: Reputation: 0
SquidGuard Whitelists Failing.


Hi Guys,

I have Squid and Squidguard running but no matter what I do I cannot seem to get my whitelists working. I have a slightly strange squidguard.conf in that the redirects are dest section of the blacklist definition. I have my whitelist deffined at the top of the squidguard config file. currently I only have one site that I need through:

*.icnetwork.co.uk

The * is not in the whitelist config but there are many sub-domains off this site that I need access to. I cannot get my whitelist to work unless I am very specific with the url path.

any ideas?
 
Old 06-04-2007, 12:23 PM   #2
RTYM
LQ Newbie
 
Registered: Jun 2007
Location: Malaysia
Distribution: CentOS, SuSE
Posts: 4

Rep: Reputation: 0
Did you restart your Squid daemon using /etc/init.d/squid reload (I'm using CentOS or RHEL) and take a look at squidGuard log?
If you see your squidGuard log showing that it goes into Emergency mode, then your squidGuard configuration file contains error.
 
Old 06-05-2007, 03:44 AM   #3
Ratty_UK
LQ Newbie
 
Registered: Apr 2007
Posts: 7

Original Poster
Rep: Reputation: 0
When changing the squidGuard config I always spawn a new squidguard in debug mode so that I can watch the output. I can confirm that squidguard is not in emergancy mode.

Ratty
 
Old 06-05-2007, 10:17 AM   #4
Ratty_UK
LQ Newbie
 
Registered: Apr 2007
Posts: 7

Original Poster
Rep: Reputation: 0
SOLVED:

The whitelist was not in the correct format for SG so it was ignoring the entry.
 
Old 07-10-2017, 01:35 AM   #5
CaptainDerp
LQ Newbie
 
Registered: Mar 2013
Posts: 27

Rep: Reputation: Disabled
Lightbulb Whitelists

I know this is an ancient thread, but I believe this may be relevant for anybody researching the topic.

There are free, actively maintained whitelists available from http://whitelists.squidblacklist.org that can be used for this exact purpose.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
error: mail command failed for /var/log/squidguard/squidGuard.log.6 Niceman2005 Linux - Networking 1 01-22-2009 01:24 PM
compiz failing, GLcore.so failing to load Schrambo Linux - Desktop 4 02-23-2008 06:13 PM
eth1 failing on boot, IEEE firewire card driver failing, help jackuss_169 Linux - Laptop and Netbook 5 03-05-2005 07:34 AM
LILO install failing, Boot failing, but Installation fine. sramelyk Slackware 9 08-23-2003 02:37 PM
X failing to load; AddScreen/InitScreen failing for driver 0 weblion Linux - Software 1 08-01-2002 06:14 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 07:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration