LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (https://www.linuxquestions.org/questions/linux-server-73/)
-   -   Squid Proxy is unable to log "access.log" file. (https://www.linuxquestions.org/questions/linux-server-73/squid-proxy-is-unable-to-log-access-log-file-660801/)

nishith 08-06-2008 03:23 AM

Squid Proxy is unable to log "access.log" file.
 
Using FC6,X86_64,Squid as a transparent proxy server with 3128 port & iptable NAT rules.

Below is my squid.conf access.log file entry.

access_log /var/log/squid/access.log squid

Now,from the last 1 month,I am unable to see any files in access.log file. It shows 0 bytes. LAN users can access internet,but as an administrator,I am unable to check access logs through SARG tool.

What to do? How to sort out this "access.log" file problem?

Below is my access.log file permission.

-rw-r----- 1 squid squid 51453214 Aug 6 14:08 access.log
-rw-r----- 1 squid squid 16402992 Aug 3 04:03 access.log.1.gz
-rw-r----- 1 squid squid 14094918 Jul 27 04:03 access.log.2.gz
-rw-r----- 1 squid squid 10417650 Jul 20 04:03 access.log.3.gz
-rw-r----- 1 squid squid 29096 Aug 6 13:55 cache.log
-rw-r----- 1 squid squid 24714 Aug 3 04:03 cache.log.1.gz
-rw-r----- 1 squid squid 21185 Jul 27 04:03 cache.log.2.gz
-rw-r----- 1 squid squid 1616684 Jul 20 04:03 cache.log.3.gz
-rw-r--r-- 1 root root 10471 Aug 6 12:30 squid.out
-rw-r----- 1 squid squid 72105163 Aug 6 14:08 store.log
-rw-r----- 1 squid squid 37367454 Aug 3 04:03 store.log.1.gz
-rw-r----- 1 squid squid 33106680 Jul 27 04:03 store.log.2.gz
-rw-r----- 1 squid squid 25945773 Jul 20 04:03 store.log.3.gz

What to do?


Waiting for Replies,

Nishith Vyas.

junpa 08-06-2008 08:26 AM

From your previous post it seems that you did some kind of upgrade.
You may want to go back over your configuration files for squid and SARG and make sure the settings are still the same.

Also the listing shows access.log is greater than 0 bytes

nishith 08-07-2008 03:21 AM

Quote:

Originally Posted by junpa (Post 3238651)
From your previous post it seems that you did some kind of upgrade.
You may want to go back over your configuration files for squid and SARG and make sure the settings are still the same.

Also the listing shows access.log is greater than 0 bytes

I have 2 Squid Proxy servers in my office.

Now,I have same configuration of both squid servers.But,only 1st Squid Server isn't generating access.log file.

the 2nd squid server is working normally & SARG is running on this linuxbox.

I would like to know that If both squid proxy settings are same,then why One Squid server can't make output of access.log file?

My syslog service is also running fine.Tell me what are the other services needs to be check for squid access.log ?

sleepyhomme 08-07-2008 07:05 AM

Maybe have a check on the logrorate file for the squid.

See whether there is any "postrotate" directive which reload the squid.
Code:

killall -HUP squid

nishith 08-08-2008 01:07 AM

Quote:

Originally Posted by sleepyhomme (Post 3239763)
Maybe have a check on the logrorate file for the squid.

See whether there is any "postrotate" directive which reload the squid.
Code:

killall -HUP squid

"killall -HUP squid" command is showing no error message.
After the above commands,what needs to be check for squid access.log?

Waiting.

sleepyhomme 08-08-2008 11:23 PM

I mean if the reload is missing from post-rotate, the daemon won't be able to append the log to the file.

If it is there and the log still 0 bytes, i got no idea.. See whether there is any experts can help. Please let me know the root cause too!

nishith 08-10-2008 12:00 AM

Quote:

Originally Posted by sleepyhomme (Post 3241515)
I mean if the reload is missing from post-rotate, the daemon won't be able to append the log to the file.

If it is there and the log still 0 bytes, i got no idea.. See whether there is any experts can help. Please let me know the root cause too!

OK Sir.

I will try in my way.

Thanks for your support.If i get soln.then I will put onto LQ also.


All times are GMT -5. The time now is 06:09 AM.