LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 07-23-2008, 08:48 AM   #1
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Gurgaon, India
Distribution: Cent OS 6/7
Posts: 4,629

Rep: Reputation: Disabled
Squid giving about init_cache_dir


Hey all,
I am running RHEL5.
I just downloaded the squid rpm from the site and did not change the default squid.conf file and tried to start squid by service squid start command and this is the error that I get.

=======================================================================
#service squid start
init_cache_dir /var/spool/squid... /etc/init.d/squid: line 54: 4528 Aborted $SQUID -z -F -D >>/var/log/squid/squid.out 2>&1
Starting squid: /etc/init.d/squid: line 53: 4529 Aborted $SQUID $SQUID_OPTS >>/var/log/squid/squid.out 2>&1
=======================================================================

I am already running the squid on RHEL4 and it is running well.
What should I be looking at specifically to get this running ?
 
Old 07-23-2008, 09:08 AM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 22,453

Rep: Reputation: 6102Reputation: 6102Reputation: 6102Reputation: 6102Reputation: 6102Reputation: 6102Reputation: 6102Reputation: 6102Reputation: 6102Reputation: 6102Reputation: 6102
Quote:
Originally Posted by linuxlover.chaitanya View Post
Hey all,
I am running RHEL5.
I just downloaded the squid rpm from the site and did not change the default squid.conf file and tried to start squid by service squid start command and this is the error that I get.

I am already running the squid on RHEL4 and it is running well.
What should I be looking at specifically to get this running ?
You installed it, but did not configure it? Do your directories exist? Permissions correct? Users????

Check out the configuration guide:

http://www.deckle.co.za/squid-users-...uration_Basics
 
Old 07-23-2008, 09:15 AM   #3
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Gurgaon, India
Distribution: Cent OS 6/7
Posts: 4,629

Original Poster
Rep: Reputation: Disabled
Everything is ok. I am already running a squid on RHEL4.
This is on RHEL5. This is the only difference.
I just want the service to start. Then I can configure it to my liking.
 
Old 07-23-2008, 10:25 AM   #4
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 22,453

Rep: Reputation: 6102Reputation: 6102Reputation: 6102Reputation: 6102Reputation: 6102Reputation: 6102Reputation: 6102Reputation: 6102Reputation: 6102Reputation: 6102Reputation: 6102
Quote:
Originally Posted by linuxlover.chaitanya View Post
Everything is ok. I am already running a squid on RHEL4.
This is on RHEL5. This is the only difference.
I just want the service to start. Then I can configure it to my liking.
You have to CONFIGURE it before you can START IT. Without the directories/users/permissions correct first, the service won't start. If you already have it running on RHEL4, you must have done this on that box.

You can try to copy your squid configuration from the RHEl4 box to the 5 box, and see what happens, but if you haven't gone through the install procedure and set everything else up, chances are it won't work.
 
Old 07-23-2008, 11:10 PM   #5
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Gurgaon, India
Distribution: Cent OS 6/7
Posts: 4,629

Original Poster
Rep: Reputation: Disabled
I tried even that. I tried the same configuration that is already running, something that I want to run, and without changing anything in the squid.conf file.
When I said I tried with no configuration means that I did not change that default squid.conf file.
 
Old 07-23-2008, 11:53 PM   #6
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Gurgaon, India
Distribution: Cent OS 6/7
Posts: 4,629

Original Poster
Rep: Reputation: Disabled
Solved. The error was regarding the fully qualified hostname.
I set it and squid started.
 
Old 08-01-2008, 10:02 PM   #7
ubuntu777
LQ Newbie
 
Registered: Jul 2008
Posts: 4

Rep: Reputation: 0
can u plz explain the exact details how you solved the issue. I am having the same problem and unable to resolve it on Fedora 7
 
Old 08-02-2008, 12:14 AM   #8
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Gurgaon, India
Distribution: Cent OS 6/7
Posts: 4,629

Original Poster
Rep: Reputation: Disabled
First to test it, just remove system hostname from /etc/hosts file. Let it be localhost.localdomain. Once it is up and running with this hostname you can set it up for the FQDN your domain will have.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
squid + giving full access to a particular url arsha Linux - Server 1 06-06-2008 01:05 AM
LDAP authentication for squid squid 2.6.STABLE16 release 2.fc8 farrukhndm Linux - Security 2 04-03-2008 01:57 AM
squid giving error while authenticating with Microsoft ADS dsids Linux - Software 0 03-26-2007 05:20 AM
squid failed. The error was: init_cache_dir Aurelien Onlabi Linux - Software 1 07-19-2006 05:29 PM
squid conf: squid failed when I type insert redirect_program /usr/bin/squidguard Niceman2005 Linux - Software 1 11-24-2004 02:29 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 10:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration