LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 06-09-2008, 06:24 AM   #1
zoltans
LQ Newbie
 
Registered: Oct 2004
Location: Cape Town, South Africa
Distribution: Ubuntu
Posts: 3

Rep: Reputation: 0
squid acl with NFS & SAMBA


Hi,
googled to death over the last few hours.....

I have an ubuntu 7.10 server called gm0 running squid and a pile of other stuff for the office.

I have installed both SAMBA & NFS on this server.
This server (gm0) can mount other linux boxes & windows boxes (via fstab) on the internal network, however none of the internal network boxes can mount anything shared on gm0.

With NFS I get:
root@gl0:/etc# mount /mnt/gm0_home
mount to NFS server 'gm0' failed: server is down.
mount: backgrounding "gm0:/home"

I have checked /etc/exports and all the other stuff (against all the gl0, gl1 etc boxes (which are Ubuntu 6.06) and they seem fine.

I am now suspecting squid.
I have added tcp port 2049 to the squid.conf acl list

How do I open the UDP 2049 port?

Can anyone suggest anything else for me to try?

TIA,
Zoltan
 
Old 06-11-2008, 07:04 AM   #2
p_s_shah
Member
 
Registered: Mar 2005
Location: India
Distribution: RHEL 3/4, Solaris 8/9/10, Fedora 4/8, Redhat Linux 9
Posts: 237
Blog Entries: 1

Rep: Reputation: 34
Please check for iptables rules, not for SQUID acls.
As per my understanding, you may have blocked port for NFS while configuring iptables rules for SQUID. Still not sure, take out one machine from squid config and test NFS.

I haven't worked with Ubuntu, so not sure if there is any feature like SElinux in Fedora. If there is, make sure those features are disable.

I hope you have already checked for various NFS problems and troubleshoot using rpcinfo and other daemon related issues on gm0.

Please revert back with your findings.
 
Old 06-11-2008, 11:46 AM   #3
zoltans
LQ Newbie
 
Registered: Oct 2004
Location: Cape Town, South Africa
Distribution: Ubuntu
Posts: 3

Original Poster
Rep: Reputation: 0
Problem is solved.

Yes - you are quite right.

The problem was the firewall ports were not open, so I was banging my head on the wrong wall.

For me, as a firehol user, I just had to add the following to /etc/firehol/firehol.conf:

(within the interface eth0 INSIDE src "192.168.0.0/24"
section)
server portmap accept
server nfs accept
Note portmap MUST also be opened.


Thanks again for responding.

Regards
Zoltan.
[query closed]
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Squid ACL to regulate uploads & downloads ~=gr3p=~ Linux - Networking 1 02-08-2006 01:03 AM
nfs&samba alok.rhct Linux - Networking 2 01-10-2006 12:34 PM
difference between NFS&SAMBA alok.rhct Linux - General 2 01-10-2006 11:47 AM
Squid acl help cgelectek Linux - Networking 3 11-11-2005 12:04 AM
Squid ACL zeroability Linux - Networking 2 01-13-2003 10:30 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 12:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration