LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 07-17-2008, 10:54 PM   #1
aunglay
LQ Newbie
 
Registered: Jul 2008
Posts: 6

Rep: Reputation: 0
Software Raid1 with Fedora Core9!!! urgently need your help


Hi everybody!!

i really need your help.i installed Fedora core9 with Software Raid1.i was setup 2 Sata Harddisk on my Server.First i made 2 Software Raid partition on each harddisk.1 software raid space is 100Mb for boot.2 software raid space is maximum of my harddisk space for root partition except swap partition.finally i got md0 for my boot partition & md1 for my root partition.After first boot ,i installed grub command to boot with 2 harddisk as given below,
grub
root (hd0,0)
setup (hd0)
root (hd1,0)
setup (hd1)
quit

My problem is here that if i remove 1 harddisk,i can boot with any harddisk but it's not complete boot up.it was stopped half of boot processing then ask root password to repair file system.What should i do to complete boot up & running a good linux server.i wanna to know another thing that can i use swap partition with raid1 ?
If i remove any harddisk this error message appear like that

Checking Filesystems
/dev/md1:clean, 4543466/4546567files,464564/454354 blocks
fsck.ext3 : Invalid argument while trying to open /dev/md0 /dev/md0:
--------------------------
=------------------------
Give root password for maintenance
(or type Control-D to continue) :

Last edited by aunglay; 07-18-2008 at 04:43 AM.
 
Old 07-18-2008, 12:28 AM   #2
ddaemonunics
Member
 
Registered: May 2008
Location: Romania
Distribution: Debian
Posts: 242

Rep: Reputation: 41
Well I also have a software RAID 1 on Debian server
This is part of my grub file

title Debian GNU/Linux, kernel 2.6.25-2-686
root (hd0,0)
kernel /vmlinuz-2.6.25-2-686 root=/dev/md1 ro quiet
initrd /initrd.img-2.6.25-2-686

title Debian GNU/Linux, kernel 2.6.25-2-686
root (hd1,0)
kernel /vmlinuz-2.6.25-2-686 root=/dev/md1 ro quiet
initrd /initrd.img-2.6.25-2-686

Adapt it to your situation and see if it works..

It should work..I have a few sistems with software raid 1.


/dev/md1 is my root partition ( / )
hd0,hd1 my discs
hd0,0 and hd0,1 are the partitions where grub is installed.
 
Old 07-18-2008, 03:16 AM   #3
aunglay
LQ Newbie
 
Registered: Jul 2008
Posts: 6

Original Poster
Rep: Reputation: 0
i have some manual concerning with Software raid 1.if u want it plz give ur email address here.i'll send mail to u.
 
Old 07-18-2008, 03:51 AM   #4
nhydra
Member
 
Registered: May 2006
Distribution: Fedora Core, FreeSpire, PC-BSD, NetBSD
Posts: 96

Rep: Reputation: 15
Could you please post your partition information?
Also some info about the mount points would be very useful.
 
Old 07-18-2008, 04:53 AM   #5
aunglay
LQ Newbie
 
Registered: Jul 2008
Posts: 6

Original Poster
Rep: Reputation: 0
if i type like this command in mylinux : fdisk -l

Device Boot Start End Blocks Id System
/dev/sda1 * 1 13 104391 fd Linux raid autodetect

/dev/sda2 14 526 3423232+ 82 Linux swap /Solaris

/dev/sda3 527 30401 239970937+ fd Linux raid autodetect

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 13 104391 fd Linux raid autodetect

/dev/sdb2 14 526 3423232+ 82 Linux swap /solaris

/dev/sdb3 527 30401 239970937 fd Linux raid autodetect.

if i type like that : cat /pro/mdmstat

Personalities : [raid1] [raid6] [raid5] [raid4]
md0 : active raid1 sda1[1] sdb1[0]
104320 blocks [2/2] [UU]

md1 : active raid1 sdb3[2] sda3[1]
239970816 blocks [2/1] [_U]
[=====>...............] recovery = 27.2% (65495360/239970816) finish=38.1min speed=76133K/sec

unused devices: <none>
[root@linuxsrv ~]#

if i type like that : vi /etc/fstab

/dev/md1 / ext3 defaults 1 1
/dev/md0 /boot ext3 defaults 1 2
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
UUID=2a3d0bfc-ff98-40a4-a40c-8231f236af44 swap swap defaults 0 0
UUID=0fc71bbd-5091-43d7-8956-bfbbb31ce83c swap swap defaults 0 0
~

Last edited by aunglay; 07-18-2008 at 04:58 AM. Reason: to add some information
 
Old 07-18-2008, 10:13 AM   #6
ddaemonunics
Member
 
Registered: May 2008
Location: Romania
Distribution: Debian
Posts: 242

Rep: Reputation: 41
I think your raid is not setup correctly.
Please go on howtoforge and search for raid howto.
If you follow the steps you should get a basic raid setup.

If you're not sure how to set it up..perform the raid setup at the OS instalation.This way you can't get it wrong.
Take a look at this

http://www.ping.co.il/node/1

PS.

The raid setup in linux is very easy if you understand the steps.
You can setup swap on raid...some do not recomend it but is have currently running on 5 production servers with swap on raid.

This
http://unthought.net/Software-RAID.H...AID.HOWTO.html

for sure will clear any questions you have regarding raid setup

If you still can't get it to work my email is unics at echod.ro

Last edited by ddaemonunics; 07-18-2008 at 10:20 AM.
 
Old 07-19-2008, 12:08 AM   #7
aunglay
LQ Newbie
 
Registered: Jul 2008
Posts: 6

Original Poster
Rep: Reputation: 0
Let me try it.i'll post soon.Anyway thank you very much.
 
Old 07-20-2008, 03:24 AM   #8
aunglay
LQ Newbie
 
Registered: Jul 2008
Posts: 6

Original Poster
Rep: Reputation: 0
If i remove any harddisk. this error message appear like that

Checking Filesystems
/dev/md1:clean, 4543466/4546567files,464564/454354 blocks
fsck.ext3 : Invalid argument while trying to open /dev/md0 /dev/md0:
--------------------------( general text message )
--------------------------( general text message )
Give root password for maintenance
(or type Control-D to continue) :


What should i do?plz continue suggest to me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
linux software raid1 porlock Linux - Newbie 1 03-18-2013 06:40 PM
driver for printer lexmark 7300 fedora core9 marciko Linux - Hardware 4 06-12-2008 03:49 PM
Have software raid1, but like to change to raid1+0 or 0+1, how? spaceuser Debian 8 03-17-2008 02:07 PM
unable to run pppoe under fedora core 6....help reqd urgently germansailor Linux - Networking 4 12-19-2006 01:34 AM
anyone who can offer help to run the software Kismet ???? urgently.......help whodunit Linux - Wireless Networking 8 11-05-2005 10:12 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 07:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration