-   Linux - Server (
-   -   Slow squid performance (

the_gripmaster 07-17-2008 04:38 AM

Slow squid performance
I am running squid-2.6.STABLE6-4.el5 on a CentOS 5.1 Server. The performance is very sluggish. However, on the same server with the same settings, the bundled squid package with RHEL 4 Update 4 is comparatively lot faster.

The server specs are as follows:
Intel(R) Xeon(TM) CPU 3.60GHz

Any clues?


Amuro-Ray2020 07-17-2008 03:24 PM

Config file
Have you compared the config files to see if there is any difference in configuration? My guess would be that CentOS's version needs more tweaking past the initial install. Maybe RHEL automatically adds their own tweaks with SQUID. There are some edits that I've done that I've noticed make SQUID faster, but I'm not sure how more experienced server admins would view my tweaks. Particularly, I've played around with some of the timeout configuration settings. However, this could lead to users not getting their pages right, so backup your config file before you go playing around too much.

Here's a list of the config file parameters and what they do (I think they're all there) You can find previous versions of SQUID there too. Like I said, take a look at some of the timeout configuration settings, they may help.

You may want to take a look at this as well, but I don't know how helpful it'll be. Squid is one of the harder services to tweak (IMHO) but a little effort goes a long way :study:

the_gripmaster 07-18-2008 06:25 AM

Actually I have already done my homework before posting. Just like CentOS 5x, the exact same problem also happens with RHEL 5x. With RHEL 4x, the problem disappears!


Amuro-Ray2020 07-18-2008 11:04 PM

Squid 3
Well with those specs, you should be good :D Have you tried Squid 3 at all? If it's not config file related, then I'd almost guess that it might not entirely be a Squid related issue. Is there anything in squid logs to suggest that there's something slowing it down? Also, maybe take a look at some other system logs too. Do other network services on this machine seem slow as well? Lastly, I'd be curious to see what the network traffic looks like during an access attempt to Squid. Wireshark would be good for that.

That's just me though. I don't know how committed you are to finding what it really is, some of these options might be too time consuming for you. If you're anything like me though, I'm betting you're going to want to hunt this issue down with a pitchfork in hand.

the_gripmaster 07-20-2008 01:42 PM

bizarre problem
I found out the problem. It's not squid.

Trying to download a file (from the Internet using HTTP) using wget on a CentOS or RHEL 5x gets me around 3kBps. However, on that exact same server with the exact same IP, the exact same download using wget on a RHEL 4x gets me around 35kBps.(I have tried reinstalling both OS several times and always get the mentioned speeds.)

Now, both RHEL 4x and RHEL 5x downloads at 10MBps if downloaded from local LAN.

Strange! Driving me nuts.

Kasper-pA- 08-05-2008 07:05 AM

I am having a similar issue.... but very strange...

I have a box running squid (our proxy box) was 2.5Xsquid... i was getting great Upload speeds (4mbit) but lousy download speeds.... 190k MAX.... so we never actually looked into it as we have around 300 users pulling from it constantly... over the weekend we upgraded to a 20mbit pipe... uploads went to 9 mbit.. but downloads stayed the same, peaked once at 192k.... SO, I went directly out of our VPN box (label) which had gave us a 19mbit down, 9 up speed..... outstanding! running the same version of squid mind you... so hardware related right? ... I redo the old proxy box.. nice new install of CentOS 5.2 ... start the yum update process and notice it's very slow.... install squid and run it as a proxy... 190k down speed again... so i swap the nic to another onboard nic... same speed result... I install a NEW nic add-on card (intel gigabit) and SAME speed results! So.. i swap out the cable.... same speed result.. and swap out the port it was on.. same speed result...

anything else i can try here.. lol this is killing me.. I'd rather not chalk up this box as a dud... but not much choice if i can't get the speeds good?



the_gripmaster 08-08-2008 11:02 AM

Did you try with RHEL 5.2? I tried with RHEL 5.2, which did mimic the exact same problem as CentOS 5.2; as they are built from the same source.

It is not the NIC, because with the same NIC, I get usual speeds inside the LAN. But whenever I go out and download something from the Internet, the speed doesn't cross a certain value. Maybe you should check this post of mine

All times are GMT -5. The time now is 10:29 AM.