LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 05-21-2013, 05:14 AM   #1
tesla75
LQ Newbie
 
Registered: May 2013
Posts: 15

Rep: Reputation: Disabled
Slow login due to /etc/ssh/sshd_config configuration


Version: Oracle Enterprise Linux 6.3
Running on VMWare Workstation


When I login to my Linux VM from putty, the third line prompting for password comes only after few seconds.

login as: root
Access denied
root@192.168.0.235's password: ---> It takes around 5 seconds to get this prompt


I managed to fix this issue after several trial and error experiments.
I have to do both Step1 and Step2 mentioned below to fix this issue. Doing either one of Step1 and Step2 won't fix the issue

Step1.
In /etc/ssh/sshd_config file
Comment the line GSSAPIAuthentication yes
and
Remove the comment for the line GSSAPIAuthentication no

It should look like below

grep GSSAPI /etc/ssh/sshd_config
# GSSAPI options
GSSAPIAuthentication no
#GSSAPIAuthentication yes
#GSSAPICleanupCredentials yes
GSSAPICleanupCredentials yes
#GSSAPIStrictAcceptorCheck yes
#GSSAPIKeyExchange no




Step2. In /etc/ssh/sshd_config file
I commented the line UseDNS yes
and then
uncommented "UseDNS no"


and did a restart using /etc/init.d/sshd restart

Soon, I'll have to use DNS functionality for this VM. So, I am worried that the above change ("UseDNS no") will prevent the VM from using the DNS service.
Is there any other workaround to make the login quick?
 
Old 05-21-2013, 07:47 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980Reputation: 1980
well either the DNS lookup works or it doesn't. If you need DNS and it doesn't work... then that needs fixing. If you can't do a reverse lookup onf the source IP address, then you should disable that option.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] rsh/ssh problem: POSSIBLE BREAK-IN ATTEMPT, most probably due to DNS configuration scampsd Linux - Newbie 5 01-04-2012 08:35 AM
Slow SSH Login Tyler_H72 Linux - Server 6 12-22-2011 04:34 PM
Slow SSH Login SystemOverload Linux - Server 1 03-22-2008 06:07 AM
ssh slow login sectioneight Linux - Software 2 01-23-2008 09:50 AM
SSH slow login dcass Linux - Software 2 02-16-2005 02:16 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 05:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration