LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (https://www.linuxquestions.org/questions/linux-server-73/)
-   -   Slow login due to /etc/ssh/sshd_config configuration (https://www.linuxquestions.org/questions/linux-server-73/slow-login-due-to-etc-ssh-sshd_config-configuration-4175462847/)

tesla75 05-21-2013 05:14 AM

Slow login due to /etc/ssh/sshd_config configuration
 
Version: Oracle Enterprise Linux 6.3
Running on VMWare Workstation


When I login to my Linux VM from putty, the third line prompting for password comes only after few seconds.

login as: root
Access denied
root@192.168.0.235's password: ---> It takes around 5 seconds to get this prompt


I managed to fix this issue after several trial and error experiments.
I have to do both Step1 and Step2 mentioned below to fix this issue. Doing either one of Step1 and Step2 won't fix the issue

Step1.
In /etc/ssh/sshd_config file
Comment the line GSSAPIAuthentication yes
and
Remove the comment for the line GSSAPIAuthentication no

It should look like below

grep GSSAPI /etc/ssh/sshd_config
# GSSAPI options
GSSAPIAuthentication no
#GSSAPIAuthentication yes
#GSSAPICleanupCredentials yes
GSSAPICleanupCredentials yes
#GSSAPIStrictAcceptorCheck yes
#GSSAPIKeyExchange no




Step2. In /etc/ssh/sshd_config file
I commented the line UseDNS yes
and then
uncommented "UseDNS no"


and did a restart using /etc/init.d/sshd restart

Soon, I'll have to use DNS functionality for this VM. So, I am worried that the above change ("UseDNS no") will prevent the VM from using the DNS service.
Is there any other workaround to make the login quick?

acid_kewpie 05-21-2013 07:47 AM

well either the DNS lookup works or it doesn't. If you need DNS and it doesn't work... then that needs fixing. If you can't do a reverse lookup onf the source IP address, then you should disable that option.


All times are GMT -5. The time now is 01:40 PM.