-   Linux - Server (
-   -   Sloow ftp transfer to NFS mounted filesystem (

peternielsen5 02-17-2008 04:05 PM

Sloow ftp transfer to NFS mounted filesystem
I've setup a vsftp server on Suse 10.3.

I've created a userprofile and in the homedir I've mounted a filesystem via NSF mount.

When trying to FTP upload i.e. 6MB data to the NFS mounted filesystem it takes something like 10 minutes to complete the upload. The filesize is 0MB until upload completes, then the filesize is correct (6MB).

When trying to upload same data into homdir, then upload completes in few seconds.

When copying same data from homedir to NFS mounted dir (filesystem) it completes in few seconds.

What could cause this problem? The NSF mounted filesystem resides on a network harddisk (netcenter) that delivers NFS and SMB services.

I've not tried to mount as SMB mount.

Brian1 02-17-2008 06:32 PM

Are you using the async option on your exports share of nfs?


peternielsen5 02-21-2008 05:15 PM

WD Netcenter
Hi Brian,

Thank you for your reply. Well I'm not sure. It's a WD netcenter (networked hardisk), and the specs do not reviel sync/async communication. When doing a portscan towards the netcenter, I get: Open TCP Port: 2049 nfsd

I'd just tried to firmware upgrade the netcenter - and it did not make any difference.

Brian1 02-22-2008 07:33 PM

Never used one of those devices so no idea of the options. browsed Western Digital tech support and found nothing. Only thing is it says NFS for macs not sure if NFS under MAC computers differ.


peternielsen5 03-04-2008 04:44 AM

solution found
I managed to find a solution.

In stead of mounting the filesystem as a NFS mount, I'd mounted the filesystem as type cifs.

That did the trick.

All times are GMT -5. The time now is 07:59 PM.