LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 09-03-2007, 11:41 PM   #1
kerinism1
LQ Newbie
 
Registered: Jun 2007
Posts: 8

Rep: Reputation: 0
Sendmail not working quite right


I have a problem with my Sendmail not working right and would like to know if someone can help me to make sure I have it set up right.

I have a server computer running RHEL4 on it. I am going to be using it to run as a web server with Apache, MySQL, and PHP (all of which are configured properly, as far as I can tell). However, I am trying to set up Sendmail so that when I design a web site for a client, I can host it for them and give them email addresses (i.e. joebloe@theirsite.com). I have set it up with cyrus to allow for pop3 and have the following installed: cyrus-sasl-md5-2.1.19-5.EL4
cyrus-sasl-devel-2.1.19-5.EL4
cyrus-sasl-ntlm-2.1.19-5.EL4
cyrus-imapd-nntp-2.2.10-1.RHEL4.1
cyrus-sasl-2.1.19-5.EL4
cyrus-sasl-plain-2.1.19-5.EL4
cyrus-sasl-2.1.19-5.EL4
cyrus-imapd-2.2.10-1.RHEL4.1
cyrus-imapd-utils-2.2.10-1.RHEL4.1
cyrus-sasl-gssapi-2.1.19-5.EL4
cyrus-imapd-murder-2.2.10-1.RHEL4.1
cyrus-sasl-md5-2.1.19-5.EL4
cyrus-sasl-plain-2.1.19-5.EL4

My current setup allows me to email locally on the machine and send outbound emails but not receive inbound emails. The checking I have done is sending an email from my Root account to my hotmail account and then sending an email to a user I set up for myself (non-root account so I can disable root logins and su to root). With outgoing mail, the address shows up as postmaster@<name_of_nameserver> rather than postmaster@<hostname> and when I try to send an email to my non-root user, I get these error messages in my maillog file:

Sep 2 21:47:18 ns1 sendmail[2699]: l834lH4N002699: from=<<myaccount>@hotmail.com>, size=850, class=0, nrcpts=1, msgid=<BAY106-F3803E779DBFB6837F3246AD0C90@phx.gbl>, proto=ESMTP, daemon=MTA, relay=bay0-omc3-s37.bay0.hotmail.com [65.54.246.237]
Sep 2 21:47:18 ns1 sendmail[2702]: l834lH4N002699: Warning: program /usr/lib/cyrus-imapd/deliver unsafe: No such file or directory
Sep 2 21:47:18 ns1 sendmail[2702]: l834lH4N002699: SYSERR(root): Cannot exec /usr/lib/cyrus-imapd/deliver: No such file or directory
Sep 2 21:47:18 ns1 sendmail[2701]: l834lH4N002699: to=<me@mysite.com>, delay=00:00:00, xdelay=00:00:00, mailer=cyrus, pri=120850, dsn=4.0.0, stat=Operating system error
Sep 2 21:53:01 ns1 master[2922]: about to exec /usr/lib64/cyrus-imapd/ctl

So, I am hoping someone can either help me or point me to a good How-To on setting up Sendmail with pop3. If you want more info on how I have set things up, please let me know and I can post/email any settings you need.

Last edited by kerinism1; 09-03-2007 at 11:42 PM.
 
Old 09-04-2007, 08:00 AM   #2
ScooterB
Member
 
Registered: Sep 2003
Location: NW Arkansas
Distribution: Linux Redhat 9.0, Fedora Core 2,Debian 3.0, Win 2K, Win95, Win98, WinXp Pro
Posts: 344

Rep: Reputation: 31
Try taking a look here: http://www.faqs.org/docs/Linux-HOWTO...MAP.html#ss7.1

Repost if you still have questions/problems!
 
Old 09-04-2007, 09:36 AM   #3
kerinism1
LQ Newbie
 
Registered: Jun 2007
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks, will take a look at it soon and let you know how I make out. I think I may have figured it out somewhat but am not sure. The path it was using (in the error logs) is different than the actual path so I changed it in the sendmail.cf file. However, I have tried to run "make" while in my mail directory and also restarting sendmail but it still reads the old path directory.

I will try again later and let you know.
 
Old 09-04-2007, 11:50 AM   #4
ScooterB
Member
 
Registered: Sep 2003
Location: NW Arkansas
Distribution: Linux Redhat 9.0, Fedora Core 2,Debian 3.0, Win 2K, Win95, Win98, WinXp Pro
Posts: 344

Rep: Reputation: 31
I think Fedora uses the M4 engine by default. Try entering this at the command line: "m4 /etc/mail/sendmail.mc > /etc/mail/sendmail.cf" No quotation marks. If that isn't the right path for your machine then enter in the correct one.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
sendmail is not working & on $prompt the cmd sendmail hangs Pavan mahoorker Linux - Software 1 04-04-2006 03:57 PM
Help Getting Sendmail working Like I want it shilo Slackware 14 06-07-2004 01:34 PM
Sendmail / Mailertable not working! topkart94 Linux - Networking 6 03-05-2004 11:27 AM
Sendmail seems working but not Swift&Smart Linux - Software 2 05-14-2003 07:14 AM
Sendmail not working at all. EL3CTRO Linux - Networking 13 05-03-2003 06:06 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 04:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration