LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 07-21-2008, 09:38 AM   #1
ponganthony
LQ Newbie
 
Registered: Oct 2007
Location: Hong Kong
Posts: 21

Rep: Reputation: 0
Sendmail MASQUERADE_AS() not working


Dear All,

I have tried to set up Sendmail on a Fedora 9 computer.

I used the default sendmail.mc file by modifying only one line:
MASQUERADE_AS(`mydomain.com')dnl

It works fine locally on the single machine, sending and receiving mails except one defect. It does not masquerade. All mail senders are shown as:
from=<user@host1.mydomain.com>

What had I done wrong? What had I missed? Where should I look into first?
(/var/log/maillog content showing stat=Sent)
Please help.

Anthony Pong
 
Old 07-21-2008, 05:57 PM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,415
Blog Entries: 55

Rep: Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590Reputation: 3590
Having MASQUERADE_DOMAIN(mydomain.com)dnl together with FEATURE(masquerade_entire_domain)dnl should make sure all 'user @ hostname.somedomain' get the 'user @ mydomain' treatment. Note there's a difference in delivery between local and remote users. Because of that you best test masquerading by sending e-mail to a remote address and *then* check if everything you need is properly replaced. (Also see options searching LQ for sendmail and masquerading, your local sendmail-doc package or http://www.sendmail.org/m4/features.html)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing port in sendmail, sendmail not working. flschou Linux - Newbie 4 01-16-2008 09:03 AM
Sendmail not working quite right kerinism1 Linux - Server 3 09-04-2007 11:50 AM
sendmail is not working & on $prompt the cmd sendmail hangs Pavan mahoorker Linux - Software 1 04-04-2006 03:57 PM
Sendmail seems working but not Swift&Smart Linux - Software 2 05-14-2003 07:14 AM
Sendmail not working at all. EL3CTRO Linux - Networking 13 05-03-2003 06:06 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 04:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration