LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 12-17-2008, 06:31 AM   #16
p_s_shah
Member
 
Registered: Mar 2005
Location: India
Distribution: RHEL 3/4, Solaris 8/9/10, Fedora 4/8, Redhat Linux 9
Posts: 237
Blog Entries: 1

Rep: Reputation: 34
please try following


Possible cause may be your system is not configured to relay mails to separate SMTP server.
Quote:
#grep "DS" /etc/mail/sendmail.cf
DS
# Return-Receipt-To: header implies DSN request
# DHParameters (only required if DSA/DH is used)

#grep "SMART_HOST" /etc/mail/sendmail.mc
dnl define(`SMART_HOST',`smtp.your.provider')
[root@EL385 ~]#
SMTP Server is a seperate server.
1. Take backup of sendmail.mc and sendmail.cf before editing them.
2. Replace "smtp.your.provider" with your SMTP server qualified name in sendmail.mc file. Make sure you are able to ping, as well as telnet <SMTP Server> 25 from konsole.
3. Regenerate sendmail.cf using
m4 /path/to/sendmail.mc > /path/to/sendmail.cf
4. Restart sendmail service.
5. Try sending mail and also paste logs.

Quote:
The Test #telnet <> 25 works and tested successfuly.
But why the remote user not receiving the mail.
Can you run the test again and copy/paste the complete session ?
Are you doing telenet to SMTP server or localhost ?
Can you double check that remote SMTP server has no restriction for relaying mail from your system ?
 
Old 12-17-2008, 09:31 AM   #17
robertwolfe
Member
 
Registered: Apr 2005
Location: Grand Island, NY
Distribution: Ubuntu and Debian
Posts: 57

Rep: Reputation: 16
Quote:
Originally Posted by your_shadow03 View Post
Whenever I am running this command on the command line on RHEL I am getting the error:

Code:
[root@EL385 ~]# echo "it is my job"| mail -vv aaina@gmail.com
WARNING: local host name (EL385) is not qualified; see cf/README: WHO AM I?
aaina@gmail.com... Connecting to [127.0.0.1] via relay...
220 ssa.loga.com ESMTP Sendmail 8.13.1/8.13.1; Wed, 17 Dec 2008 04:36:20 GMT
>>> EHLO 
250-ssa.loga.com Hello localhost.localdomain [127.0.0.1], pleased to meet you
250-ENHANCEDSTATUSCODES
250-PIPELINING
250-8BITMIME
250-SIZE
250-DSN
250-ETRN
250-AUTH GSSAPI DIGEST-MD5 CRAM-MD5
250-DELIVERBY
250 HELP
>>> MAIL From:<root@EL385> SIZE=39 AUTH=root@EL385
250 2.1.0 <root@EL385>... Sender ok
>>> RCPT To:<aaina@gmail.com>
>>> DATA
Code:
Dec 17 04:35:19 tuxbuddy sendmail[5834]: My unqualified host name (EL385) unknown; sleeping for retry
Dec 17 04:38:12 EL385 sendmail[2347]: mBC8ASsl014838: to=<root@bl18dl385>, delay=4+20:26:28, xdelay=00:00:35, mailer=esmtp, pri=10473308, relay=EL385.logica.com., dsn=4.0.0, stat=Deferred: Name server: bl18dl385.loga.com.: host name lookup failure
Dec 17 04:38:52 EL385 sendmail[2347]: mBC4ASsl010087: to=<root@EL385>, delay=5+00:06:30, xdelay=00:00:40, mailer=esmtp, pri=10833438, relay=EL385.loga.com., dsn=4.0.0, stat=Deferred: Name server: EL385.loga.com.: host name lookup failure
Dec 17 04:38:52 EL385 sendmail[2347]: mBC4ASsl010087: mBH4Aaab002347: return to sender: Cannot send message for 5 days
Dec 17 04:38:52 EL385 sendmail[2347]: mBH4Aaab002347: to=root, delay=00:00:00, xdelay=00:00:00, mailer=local, pri=34994, dsn=2.0.0, stat=Sent
I checked /etc/hosts file too but everything seems right?
Completely confused !!!
Most likely this machine is not in DNS (as opposed to being in your /etc/hosts file). Check the DNS entry for this machine to see if it is indeed in DNS. If not, put in a record for it and you should be all set.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sendmail issue bman22 Linux - Networking 7 07-23-2008 01:57 AM
Sendmail Issue kvelarde Linux - Server 2 05-13-2008 11:50 AM
Sendmail issue (did not issue MAIL/EXPNVRFY/ETRN ...) Blackout_08 Linux - Server 0 08-08-2007 01:10 PM
Sendmail Issue! Atif_Khan Linux - Networking 5 02-16-2005 01:05 PM
sendmail issue archangel Linux - General 6 11-13-2002 08:17 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 10:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration