LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 11-29-2013, 09:43 AM   #16
ronramiro
LQ Newbie
 
Registered: Jul 2006
Posts: 2

Rep: Reputation: 0
solved


Quote:
Originally Posted by zafar_dandoti View Post
probably you must have created directories by becoming root so the directories are owned by user root!

modify the directory permissions so that samba users can read/write to them..
I had the same message: error NT_STATUS_WRONG_PASSWORD

To access local and remote (windows) I change smb.conf file in Networking Section:
interfaces = 127.0.0.0/8 eth0
for # interfaces = 127.0.0.0/8 eth0

and:
bind interfaces only = yes
for # bind interfaces only = yes


hope this help
 
Old 03-13-2014, 04:21 PM   #17
Bruce from Canada
Member
 
Registered: Feb 2012
Location: Greater Montreal, QC, Canada (Eastern NA time zone as NYC)
Distribution: Fedora, multiple versions
Posts: 56
Blog Entries: 2

Rep: Reputation: Disabled
F20 and Samba - multiple complaints existing.

I have recently installed F20 on a new machine. I have also had problems with F20 and Samba.

On researching in various places and doing some of my own experimenting, I see that this is not a single issue. This also correlates with the diverse plethora of complaints I have seen.

I was able to get Filezilla to work through Samba, but so far not Nautilus.

For now I have a work-around that fills the bill temporarily, but that is complex and hardware intensive. I doubt if many users would like to deal with that approach.

Part of this is a fault in the way SELINUX handles authenticating of Samba, and I suspect the problem, or at least part of it is hard coded, and may have to wait until the major developers do a fully compiled respin of the pair as an RPM. That will take a lot of developers' time, so it may never appear in F20.

I have heard it posted that F21 is to have a new core, and so is not expected to arrive until (somebody's guess) about august or September or 2014.

Given what happened with the release of F18, I would be little surprised if that didn't result in F21 being months later than that.

I suggest people experiencing problems with any of these issues do a lot of research, or see if they can set up the whole thing on NFS, adding what they may need to their windows users to access through NFS.

It is also possible that the problem might bre solved with a NAS box that can be accessed simultaneously from an embedded Samba server and an embedded NFS server simultaneously, or by using 2 NAS boxes, bilaterally cross-synced, one for each.

In such a case, the traffic is apt to be heavy, so the 2 NAS boxes might well be placed on the Lower side of a Gb. managed switch, so as not to impose the cross-sync traffic on the main network.

Bruce from Canada

[QUOTE=Teckno;4349454]I'm just trying to set up a simple file server on my OpenIndiana box, but no matter what tutorial or smb.conf setting I seem to try I get the same problem.

First, my latest smb.conf:
Code:
[global]
    netbios name = CASPER
    workgroup = LAN
    server string = File Server
    log file = /var/samba/log/smbd.log
    max log size = 100
    encrypt passwords = yes
    smb passwd file = /etc/samba/smbpasswd
    security = share
    unix password sync = Yes
    passwd program = /usr/bin/passwd %u
    passwd chat = *New*UNIX*password* %n\n *ReType*new*UNIX*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*    
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192    

[media]
    comment = Media Files
    path = /share/media
    public = yes
    read only = no
        
[sam]
    comment = Sams Files
    path = /share/userfiles/sam
    valid users = sam
    public = no
    writable = yes
    printable = no
I also made sure to add both the unix user and smb user to the server. I have the same user name "sam" on my windows desktop, and ubuntu laptop, and I used the same password. Ive tested the accounts and they seem to work fine. I can login to the unix account and samba shows that it has a user named sam

The problem:
The server and shares show up just fine, and the media share is readable (not writable but that most likely just a permission thing and not the issue at hand). The problem is with the private share "sam", heres what happens:

Local Test:
Quote:
sam@casper:~$ /usr/bin/smbclient //192.168.0.1/sam
Enter sam's password:
Connection to 192.168.0.1 failed (Error NT_STATUS_CONNECTION_REFUSED)[/CODE]

From my Ubuntu laptop:


And from my Windows Vista desktop I just get a login unsuccessful message.

My /var/samba/log/smbd.log is filled with these:
Code:
[2011/05/07 13:46:32.075667,  1] smbd/service.c:677(make_connection_snum)
  create_connection_server_info failed: NT_STATUS_WRONG_PASSWORD
[2011/05/07 13:46:32.079670,  1] smbd/service.c:677(make_connection_snum)
  create_connection_server_info failed: NT_STATUS_WRONG_PASSWORD
[2011/05/07 13:46:32.086242,  1] smbd/service.c:677(make_connection_snum)
  create_connection_server_info failed: NT_STATUS_WRONG_PASSWORD
and yes, I triple checked all the passwords.


From my tests it seems that samba refuses to use any sort of user other then the guest account.

I tried it with "security = user" but run into the same issue, just when I connect to the server instead of the share, so it efectivlly blocks me from the media share as well.

Im probably missing something simple thats preventing the authentication, anyone care to point it out?

Thank you
 
Old 03-13-2014, 04:53 PM   #18
Ser Olmy
Senior Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 2,921

Rep: Reputation: Disabled
Since your post quoted the OP of this ancient thread:
Quote:
Originally Posted by Bruce from Canada View Post
Code:
[global]
    netbios name = CASPER
    workgroup = LAN
    server string = File Server
    log file = /var/samba/log/smbd.log
    max log size = 100
    encrypt passwords = yes
    smb passwd file = /etc/samba/smbpasswd
    security = share
IMPORTANT: "security = share" is deprecated in (and was recently removed from) Samba and has been unsupported on the Windows platform since around 2001. It was a bad idea to use "security = share" even back when this thread was started. Windows Vista/7/8 won't know what to do when connecting to a share using this authentication mode.

Use "security = user" instead.
 
  


Reply

Tags
authentication, samba, share, users


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba: New AD users can't authenticate warci Linux - Networking 2 04-10-2006 02:18 AM
Authenticate samba users against PAM yapp Linux - Networking 0 11-24-2005 05:59 AM
authenticate samba users using the NIS manojthakkar Linux - Networking 1 07-25-2005 07:48 PM
authenticate samba users using the NIS manojthakkar Linux - General 1 02-02-2004 02:25 PM
authenticate samba users using the NIS manojthakkar Linux - Newbie 1 02-02-2004 11:45 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 06:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration