LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 10-19-2012, 12:44 AM   #16
dushyantgohil
Member
 
Registered: Aug 2011
Location: India
Distribution: Cent OS & Ubuntu
Posts: 107

Original Poster
Rep: Reputation: 3

Quote:
Originally Posted by centos123 View Post
can you tell me how you map windows user to samba server and also ubantu user to samba server. which folder you has mapped with server.beside permission their is one more reason that after getting your reply i can come to conclusion.so reply me .

---------- Post added 10-19-12 at 12:26 AM ----------

post your smb.conf file

in windows i am mapping the directory using map drive option and in ubuntu i connect using connect to server option
 
Old 10-19-2012, 02:31 AM   #17
Nikosis
Member
 
Registered: Dec 2005
Location: In front of the monitor
Distribution: Slackware
Posts: 312

Rep: Reputation: 59
Quote:
Originally Posted by dushyantgohil View Post
hi please read above post i have mentioned all the things
I did, and there is nothing, all it says is that you created a user, a pass for him, and firewall is disabled , you did not post smb.conf, neither file ownership.

You need to post as many info as you can.
-file permission
-file ownership
-configuration file
-group that your user belong to.

Otherwise, it's not gonna be possible for us to help you.

Maybe this will help.

Last edited by Nikosis; 10-19-2012 at 02:44 AM.
 
Old 10-19-2012, 04:58 AM   #18
debianguru85uk
LQ Newbie
 
Registered: Oct 2012
Posts: 10

Rep: Reputation: Disabled
Have you added line:

valid users = username

e.g. valid users = jon

for the share you are trying to access?
 
Old 10-19-2012, 06:42 AM   #19
dushyantgohil
Member
 
Registered: Aug 2011
Location: India
Distribution: Cent OS & Ubuntu
Posts: 107

Original Poster
Rep: Reputation: 3
Quote:
Originally Posted by centos123 View Post
can you tell me how you map windows user to samba server and also ubantu user to samba server. which folder you has mapped with server.beside permission their is one more reason that after getting your reply i can come to conclusion.so reply me .

---------- Post added 10-19-12 at 12:26 AM ----------

post your smb.conf file

mapping windows users using map drive option of windows and in ubuntu i am mapping using connect to server option.
 
Old 10-19-2012, 06:46 AM   #20
dushyantgohil
Member
 
Registered: Aug 2011
Location: India
Distribution: Cent OS & Ubuntu
Posts: 107

Original Poster
Rep: Reputation: 3
Quote:
Originally Posted by Nikosis View Post
I did, and there is nothing, all it says is that you created a user, a pass for him, and firewall is disabled , you did not post smb.conf, neither file ownership.

You need to post as many info as you can.
-file permission
-file ownership
-configuration file
-group that your user belong to.

Otherwise, it's not gonna be possible for us to help you.

Maybe this will help.
hi Nikosis,

check this things

[test]
path = /var/www/html/test
writeable = yes
browseable = yes
valid users = test
create mask = 0755
 
Old 10-19-2012, 10:40 AM   #21
zafar_dandoti
Member
 
Registered: Dec 2005
Location: India
Distribution: centos
Posts: 178

Rep: Reputation: 13
hi dushyant
open ur smb.conf file and add this lines
passdb backend = smbpasswd
smbpasswd file = /etc/samba/smbpasswd
quit smb.conf
testparm
$ smbpasswd -a username
new smb password
retype password
$ smbpasswd -e username

as root/sudo
service smb restart
service nmb restart

GOOD LUCK
 
Old 10-19-2012, 10:29 PM   #22
Nikosis
Member
 
Registered: Dec 2005
Location: In front of the monitor
Distribution: Slackware
Posts: 312

Rep: Reputation: 59
Try to follow the steps in a link I sent you.
 
Old 10-20-2012, 01:19 AM   #23
vishalsamyal
LQ Newbie
 
Registered: Oct 2012
Location: India
Posts: 25
Blog Entries: 3

Rep: Reputation: Disabled
First off all create a dir and share it with samba.
in samba configuration file give permission to the same user. Like:
read list = user
write list = user

after that create a user then change the dir permission to 755 also change the ownership of the same dir to user you have create.

Also check selinux and firewall status.
 
Old 10-22-2012, 12:28 AM   #24
dushyantgohil
Member
 
Registered: Aug 2011
Location: India
Distribution: Cent OS & Ubuntu
Posts: 107

Original Poster
Rep: Reputation: 3
Quote:
Originally Posted by vishalsamyal View Post
First off all create a dir and share it with samba.
in samba configuration file give permission to the same user. Like:
read list = user
write list = user

after that create a user then change the dir permission to 755 also change the ownership of the same dir to user you have create.

Also check selinux and firewall status.

hey, what if i dont want to chage ownership.
 
Old 10-22-2012, 12:40 AM   #25
dushyantgohil
Member
 
Registered: Aug 2011
Location: India
Distribution: Cent OS & Ubuntu
Posts: 107

Original Poster
Rep: Reputation: 3
Thanks for your support and replies guys.

its working now.
 
Old 10-22-2012, 05:04 AM   #26
vishalsamyal
LQ Newbie
 
Registered: Oct 2012
Location: India
Posts: 25
Blog Entries: 3

Rep: Reputation: Disabled
If you will not change ownership then nothing will be wrong but in case haven't give appropriate permission the same file or directory then you will not be able to modify the same file or folder.
 
Old 10-23-2012, 02:33 AM   #27
dushyantgohil
Member
 
Registered: Aug 2011
Location: India
Distribution: Cent OS & Ubuntu
Posts: 107

Original Poster
Rep: Reputation: 3
Quote:
Originally Posted by vishalsamyal View Post
If you will not change ownership then nothing will be wrong but in case haven't give appropriate permission the same file or directory then you will not be able to modify the same file or folder.
in that case if i provide the permission 777 than?
 
Old 10-23-2012, 10:40 AM   #28
vishalsamyal
LQ Newbie
 
Registered: Oct 2012
Location: India
Posts: 25
Blog Entries: 3

Rep: Reputation: Disabled
Then defiantly it will work.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba server not working... adlib69 Linux - Newbie 2 11-22-2006 04:36 PM
NFS and Samba shares not working on MDK10, kernel 2.6.6 server DaneM Linux - Software 1 05-29-2004 08:42 PM
samba working, then installed openSSL and not samba not working hamish Linux - Networking 3 05-17-2004 01:50 PM
My Samba Netbios Name Server is not working ViroMan Linux - Networking 9 04-25-2004 10:52 PM
Write Access on Samba Server not working urzumph Linux - Networking 2 03-04-2004 05:03 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 02:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration