LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 04-26-2011, 10:28 AM   #1
patufet99
Member
 
Registered: Dec 2005
Location: Switzerland
Distribution: Debian/Ubuntu
Posts: 34

Rep: Reputation: 15
samba server does not seem to answer when called with the server name.


Hello,

I have replaced a Samba server that was running under Debian 5. with a new server now under Debian 6. I have restored the old Samba config files that worked normally, in the new server and there is an odd behaviour that I do not understand:

On the server:

Code:
server:~$ ping server
64 bytes from server (127.0.1.1): icmp_req=1 ttl=64 time=0.024 ms
On a windows client

Code:
C:\Documents and Settings>ping server

Pinging server.fritz.box [192.168.1.100] with 32 bytes of data:

Reply from 192.168.1.100: bytes=32 time <1ms TTL=64
both work normally.


Code:
server:~$ smbclient -L 192.168.1.100 -U user
Enter user's password:
Domain=[WINDOWS] OS=[Unix] Server=[Samba 3.5.6]

        Sharename       Type      Comment
        ---------       ----      -------
        print$          Disk      Printer Drivers
        FTP             Disk      FTP Shared files
        temp            Disk
        user            Disk      Home Directories
Domain=[WINDOWS] OS=[Unix] Server=[Samba 3.5.6]

        Server               Comment
        ---------            -------
        SERVER               my server
        PC-DEMO

        Workgroup            Master
        ---------            -------
        WINDOWS              SERVER
When testing the smb server with the server's IP address it works ok.

Code:
server:~$ smbclient -L server -U user
Enter user's password:
session request to SERVER failed (Not listening for calling name)
session request to *SMBSERVER failed (Not listening for calling name)
When testing the smb server with the server's name "server" (on this case) it does not work.

Any hints?

Thank you for your help.

Regards
 
Old 04-26-2011, 11:09 AM   #2
sibe
Member
 
Registered: Apr 2011
Location: Jakarta, Indonesia
Distribution: Fedora, CentOS
Posts: 122

Rep: Reputation: 21
Hi,

can we see your smb.conf?
 
Old 04-26-2011, 11:13 AM   #3
dbmits
LQ Newbie
 
Registered: Apr 2011
Posts: 8

Rep: Reputation: 2
Hi, is nmbd running or installed ?
I think it's needed exactly for this.
 
Old 04-26-2011, 12:08 PM   #4
patufet99
Member
 
Registered: Dec 2005
Location: Switzerland
Distribution: Debian/Ubuntu
Posts: 34

Original Poster
Rep: Reputation: 15
Here is the /etc/smb.conf file

Code:
[global]
   log file = /var/log/samba/log.%m
   name resolve order = host lmhosts bcast wins
   smb ports = 139
   passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
   obey pam restrictions = yes
   username map = /etc/samba/user.map
   encrypt passwords = true
   passwd program = /usr/bin/passwd %u
   passdb backend = tdbsam
   hosts allow = 127.0.0.1, 192.168.1.0/24
   hosts deny = ALL
   dns proxy = no
   printing = cups
   server string = my server
   workgroup = WINDOWS
   printcap name = cups
   security = user
   syslog = 2
   panic action = /usr/share/samba/panic-action %d
   max log size = 1000

[homes]
   comment = Home Directories
   browseable = no
   read only = no
   create mask = 0770
   directory mask = 0770

[print$]
   comment = Printer Drivers
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   guest ok = no

[FTP]
   comment = FTP Shared files
   path = /home/ftp/
   writeable = yes
   browseable = yes
   create mask = 0770
   directory mask = 0770
   case sensitive = no

[temp]
   path= /home/temp
   public=yes

nmbd is installed and running:

Code:
server:~# ps -e
...
12557 ?        00:00:00 nmbd
12561 ?        00:00:00 smbd
12567 ?        00:00:00 smbd
...
Thank you for your comments.
 
Old 04-26-2011, 12:35 PM   #5
patufet99
Member
 
Registered: Dec 2005
Location: Switzerland
Distribution: Debian/Ubuntu
Posts: 34

Original Poster
Rep: Reputation: 15
nmbd seems to work as expected:

/var/log/samba/log.nmbd

Code:
...
[2011/04/26 18:22:14.621793,  0] nmbd/nmbd.c:71(terminate)
  Got SIGTERM: going down...
[2011/04/26 18:22:17,  0] nmbd/nmbd.c:857(main)
  nmbd version 3.5.6 started.
  Copyright Andrew Tridgell and the Samba Team 1992-2010
[2011/04/26 18:22:40.676194,  0] nmbd/nmbd_become_lmb.c:395(become_local_master_stage2)
  *****

  Samba name server SERVER is now a local master browser for workgroup WINDOWS on subnet 192.168.1.100

  *****
 
Old 04-26-2011, 12:43 PM   #6
sibe
Member
 
Registered: Apr 2011
Location: Jakarta, Indonesia
Distribution: Fedora, CentOS
Posts: 122

Rep: Reputation: 21
Quote:
Originally Posted by patufet99 View Post
hosts allow = 127.0.0.1, 192.168.1.0/24
That could be the culprit. Try change it this way :

Code:
hosts allow = 127. 192.168.1.
Port 137:udp, 138:udp, 139:tcp and 445:tcp will also need to be allowed through your firewall to enable Windows to connect to your Samba server.

Last edited by sibe; 04-26-2011 at 12:48 PM.
 
1 members found this post helpful.
Old 04-26-2011, 01:48 PM   #7
patufet99
Member
 
Registered: Dec 2005
Location: Switzerland
Distribution: Debian/Ubuntu
Posts: 34

Original Poster
Rep: Reputation: 15
Hi sibe,

thanks for your reply. I changed the host allow as you suggested and it seems to work now!
The curious thing is that it worked before, but perhaps something changed from the old samba version?

Thanks again for your help.

Regards.
 
Old 12-28-2012, 09:58 AM   #8
rhbegin
Member
 
Registered: Oct 2003
Location: Arkansas, NWA
Distribution: Fedora/CentOS/SL6
Posts: 381

Rep: Reputation: 23
Question

Quote:
Originally Posted by sibe View Post
That could be the culprit. Try change it this way :

Code:
hosts allow = 127. 192.168.1.
Port 137:udp, 138:udp, 139:tcp and 445:tcp will also need to be allowed through your firewall to enable Windows to connect to your Samba server.
I ran into this problem as well, I know this is dated but it is relevant.


I added 127.0.0.1 to the allowed host, I was not able to browse to the samba server running on CentOS 6.3 x86_64 with samba-3.5.10-125.el6.x86_64 installed.

Why is it with the service smb start the nmb process is not included?

I had to chkconfig smb & nmb on, however I could not get it to take the server name without entering it in the 'netbios name' ?

Can someone please help explain this?

thanks

Last edited by rhbegin; 12-28-2012 at 12:47 PM.
 
  


Reply

Tags
nmbd, samba, smbconf


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why Can't I get an authoritative answer from a DNS server. windbadboy Linux - Newbie 3 04-23-2011 09:27 AM
Why Can't I get an authoritative answer from a DNS server. windbadboy General 1 04-23-2011 08:45 AM
Move user files from Samba server to new samba server TheB2B Linux - Server 3 11-10-2007 08:30 PM
server to answer 3g phone, what software? fjallstrom Linux - Software 0 04-04-2006 09:56 AM
If X server (Cygwin) is the answer, I need a new Question -G- Linux - Networking 17 03-13-2003 11:09 PM


All times are GMT -5. The time now is 04:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration