LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 03-20-2008, 05:05 AM   #1
fedoraman
Member
 
Registered: Jan 2008
Posts: 51

Rep: Reputation: 15
Samba Server


Hi, I want to setup samba server on fedora core 6 in windows network.But when I try to browse the samba shared folder from the windows machine it says the given network path not found.

Any one can help me please
 
Old 03-20-2008, 05:51 AM   #2
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678
Make sure that ports 139 and 445 are not blocked by a firewall on either host.
Is the Workgroup the same for both computers?
Can you ping from one computer to another?
Are both computers on the same subnet?
 
Old 03-20-2008, 05:59 AM   #3
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
It could also be an SELinux issue - try temorarily disabling with "setenforce 0" and see if it works (setenforce 1 to re-enable)
 
Old 03-20-2008, 07:09 AM   #4
fedoraman
Member
 
Registered: Jan 2008
Posts: 51

Original Poster
Rep: Reputation: 15
when I am giving security = share than I am not able to access the path but when I am giving security = user its showing the error

global

guest account = root
load printers = yes
idmap gid = 16777216-33554431
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
null passwords = yes
winbind trusted domains only = no
public = yes
winbind use default domain = no
template shell = /bin/false
dns proxy = no
cups options = raw
server string =Gallery Server
locking = no
writeable = yes
delete readonly = yes
idmap uid = 16777216-33554431
default = images
path = /tmp/images
workgroup = gallery
os level = 20
printcap name = /etc/printcap
security = user
max log size = 50

share
[images]

comment = gallery
path = /tmp/images
public = yes
writable = yes
guest ok = yes
browseable = yes
create mask = 0777


Thanks
 
Old 03-20-2008, 07:15 AM   #5
sjreilly
Member
 
Registered: Oct 2007
Location: Edinburgh, Scotland
Distribution: Debian, CentOS, RHEL, Mint, Ubuntu
Posts: 79

Rep: Reputation: 15
Have you tried running testparm on the smb.conf file to check for errors?

Steve
 
Old 03-20-2008, 07:16 AM   #6
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678
Get rid of the "guest account = root" entry. Change it to "guest account = nobody" which is the default.
Also use the "smbpasswd" program so that Linux users and Windows users have the same name and password.
Also use a different directory for the share. Some systems delete /tmp/ files when you reboot.

A good location for a public share is under /srv/samba/.

Create the directory like this:
sudo mkdir -p /srv/samba/images
sudo chmod a=rwxt /srv/samba/images

Then edit the path entry in the share definition.
 
Old 03-20-2008, 07:24 AM   #7
fedoraman
Member
 
Registered: Jan 2008
Posts: 51

Original Poster
Rep: Reputation: 15
This is the error I am grtting when I ran testparm


[root@localhost samba]# testparm
Load smb config files from /etc/samba/smb.conf
params.c:Parameter() - Ignoring badly formed line in configuration file: configuration
params.c:Parameter() - Ignoring badly formed line in configuration file: -d /dev/nul$
Processing section "[images]"
Processing section "[gallery]"
Loaded services file OK.
WARNING: lock directory /var/cache/samba should have permissions 0755 for browsing to work
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions
 
Old 03-20-2008, 07:29 AM   #8
fedoraman
Member
 
Registered: Jan 2008
Posts: 51

Original Poster
Rep: Reputation: 15
what of I want no password for the share it means any one can access the share ans d have read and write access to the folder.
 
Old 03-20-2008, 08:12 AM   #9
sjreilly
Member
 
Registered: Oct 2007
Location: Edinburgh, Scotland
Distribution: Debian, CentOS, RHEL, Mint, Ubuntu
Posts: 79

Rep: Reputation: 15
Can you post you smb.conf file?

There _should_ be square brackets around words like global;

[global]

Here's my smb.conf

[global]

netbios name = WORKGROUP_NAME

bind interfaces only = Yes
update encrypted = Yes
map to guest = Bad User
null passwords = Yes
guest account = nobody
username map = /etc/samba/smbusers
log file = /var/log/samba/%m.samba.log
max log size = 20
smb ports = 139
hostname lookups = Yes
ldap ssl = no
guest ok = Yes

[homes]
comment = Home Directories
read only = No
create mask = 0644
browseable = No

Steve

Last edited by sjreilly; 03-20-2008 at 08:14 AM.
 
Old 03-20-2008, 08:32 AM   #10
fedoraman
Member
 
Registered: Jan 2008
Posts: 51

Original Poster
Rep: Reputation: 15
[global]

log file = /var/log/samba/%m.log
guest account = nobody
load printers = yes
idmap gid = 16777216-33554431
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
null passwords = yes
winbind trusted domains only = no
public = yes
winbind use default domain = no
template shell = /bin/false
dns proxy = no
cups options = raw
server string =Gallery Server
locking = no
writeable = yes
delete readonly = yes
idmap uid = 16777216-33554431
default = images
path = /srv/samba/images
workgroup = MSNET
os level = 20
printcap name = /etc/printcap
security = share
max log size = 50


[images]

comment = gallery
path = /srv/samba/images
public = yes
writable = yes
guest ok = yes
browseable = yes
create mask = 0777
guest account = nobody

now i am getting error you do not have permission to share the network path
 
Old 03-20-2008, 08:35 AM   #11
fedoraman
Member
 
Registered: Jan 2008
Posts: 51

Original Poster
Rep: Reputation: 15
I want user cannot have to enter the username and password they can directly enter the share path and can use the share
 
Old 03-20-2008, 10:23 AM   #12
sjreilly
Member
 
Registered: Oct 2007
Location: Edinburgh, Scotland
Distribution: Debian, CentOS, RHEL, Mint, Ubuntu
Posts: 79

Rep: Reputation: 15
I would start with a very basic config (like mine) and then modify the parameters one at a time, changing the security options etc.

Do you have Webmin installed on your box? Or SWAT?
 
Old 03-20-2008, 02:12 PM   #13
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Re: post 11, no promises, but give "force user" and " force group" a go for the share. Security = user may still require a valid user though (see man smb.conf)
 
Old 03-20-2008, 06:42 PM   #14
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678
These lines should be in the [images] service section instead:
writeable = yes
delete readonly = yes
public = yes

This line should be in the [Global] section:
guest account = nobody

When I ran testparm against your posted smb.conf, It brought up the "guest account = nobody" being in a service section.

This option just seems bad:
null passwords = yes

I don't get this one:
template shell = /bin/false
or this one:
locking = no


You can delete the winbind lines because those are the defaults.
dns proxy = no
My config uses the default "dns proxy = Yes".

idmap uid = 16777216-33554431
Where did you get these numbers from. Do you know if they are correct?

os level = 20
This is the default. You can delete this line to clean up your config file.

public = yes
guest ok = yes
public & guest ok are synonyms. You don't need to use both.

Last edited by jschiwal; 03-20-2008 at 06:53 PM.
 
  


Reply

Tags
samba


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Move user files from Samba server to new samba server TheB2B Linux - Server 3 11-10-2007 08:30 PM
samba member server as fileserver authenticating samba PDC activeq Linux - Networking 0 11-17-2006 09:44 AM
Samba domain member server (DMS) group permissions in network with a Samba PDC srosa Linux - Networking 0 05-01-2006 05:55 PM
How can I connect samba client from samba server wampire Linux - Networking 2 02-13-2006 10:38 AM
SAMBA says 'Samba Server is not accebile, you might have no permissions' Ahmad Gurchani Linux - General 1 01-01-2005 10:34 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 04:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration