LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 05-03-2007, 03:57 PM   #1
jlukensow
Member
 
Registered: Mar 2007
Posts: 33

Rep: Reputation: 15
Samba pissing me off!


Allright, here we go.

I have Samba installed on Fedora 6, I can from a Windowx box, browse the network and shares. But, on my Linux box, I can see the network and computer, however, I cannot view the shares of the Microcrap computers. Says "Contents of Network cannot be shown"

Any ideas?
 
Old 05-03-2007, 05:13 PM   #2
Brian1
LQ Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 63
What app are you using to browse the network with?

Brian
 
Old 05-03-2007, 10:38 PM   #3
ErrorBound
Member
 
Registered: Apr 2006
Posts: 280

Rep: Reputation: 31
Do you have a firewall? Try disabling it...accessing windows shares uses all sorts of weird ports that you probably have closed.

Or, it's a setting in a config file. But don't ask me which one.
 
Old 05-04-2007, 08:02 AM   #4
jlukensow
Member
 
Registered: Mar 2007
Posts: 33

Original Poster
Rep: Reputation: 15
I'm just using the GNOME, if that is what you are asking. Basically, I click on "Network Server" then a list of avaiable computers pops up, but I cant get in. I have tried disabling the Firewall, but let me try disabling the firewall on the Microsoft computers, I havent tried that yet.

Thanks
 
Old 05-06-2007, 10:26 AM   #5
ajg
Member
 
Registered: Nov 2005
Location: The People's Republic of South Yorkshire
Distribution: FC3, CentOS4&5, Hardy Heron, Mythbuntu
Posts: 62

Rep: Reputation: 15
1) On the MS box, make sure "File & Printer Sharing for Microsoft Networks" is checked under the properties of the network card. Sounds stupid I know, but it bit me in the bum the other day - assumed it was set, didn't check it and spent a good while beating my head against a wall.

2) You need to allow inbound connections on UDP ports 137 and 138, and TCP port 139 - but only from the IP addresses of the computers which need access.

If it still doesn't work, you need to make sure that "Enable NetBIOS over TCP/IP" is checked. Have a look at this for more info. If it's anything less than Windows 2000, this option won't be there.
 
Old 05-06-2007, 02:24 PM   #6
gautamatul82
LQ Newbie
 
Registered: Aug 2006
Posts: 2

Rep: Reputation: 0
Hi there....

After performing the steps listed above, we are done from the MS-Windows end, now we need to set up our Linux box.

Note if you have specified username based shares then you need to access that share using the same username which is having an access to it else you can perform the steps given below --

1) Make an entry to your /etc/fstab file in the same way as it is given -----

<//Windows share-name> <Mount dir> <FS type> <Options>

e.g.
//10.10.10.10/Upload /mnt/upload smbfs credentials=/etc/samba/pass_info,uid=201,gid=201 0 0

where --
//10.16.10.10/Upload is the name of the MS-Windows share.
/mnt/Upload is the name of the directory on which Windows
share will be mounted.
smbfs is the file system for Windows share.
credentials=/etc/samba/pass_info is a file that contains the authentication information for accessing windows share. This information is in the format
Username=abcd
Password=xyz
uid=201 is the effective UID of the linux user who will access the share.
gid=201 is the effective GID of the linux user who will access the share.
0 is used for dumping the filesystem.
0 is used for fsck (filesystem checks)


After making an entry, save your /etc/fstab file and issue the command -- mount -a

Also, the "credentials" is used to access the share if the permission has been given to a specific user else there is no need to mention the credential field in /etc/fstab file.

Check if these steps help you out and your problem gets resolved or not.




ATUL
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
K3b REALLY pissing me off mrchaos Linux - Software 4 04-28-2005 05:48 PM
XP is pissing me off!! BajaNick General 23 12-06-2003 05:31 AM
J2RE 1.4. Pissing me off.. JoeLinux Linux - Software 5 12-02-2003 04:26 PM
smbpasswd is pissing me off. Need help JoeLinux Linux - Networking 2 06-09-2002 12:04 AM
Virtualy....... pissing me OFF! yogee Linux - General 6 08-13-2001 11:37 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 06:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration