-   Linux - Server (
-   -   rsync v.3.0.7 over cygwin 1.7.6 fails... (

blainemiller 06-09-2011 01:15 PM

rsync v.3.0.7 over cygwin 1.7.6 fails...

I'm trying to rsync files and directories from a RedHat linux host(v 4.5 & 4.7) to a Windows server 2003R2 Standard Edition with cygwin running. I'm executing the rsync command from the cygwin shell. The transfer involves rsync'ing approximately 1 TB of data from the linux server to the windows server. After about 280+GB of data transfer, the transfer just dies.

There seems to be no particular file or directory that the transfer stops at. I'm able to rsync GB's of data from other linux hosts to this cygwin server with no problem. Files and directories rsync fine.

The network infrastructure is essentially the same regardless of the server being rsync'ed in that it is GB Ethernet running through Cisco GB switches. There appear to be no glitches or hiccups across the network path.

I've asked the folks at if they know of any problems or issues. Their response has been neutral in that if the version of rsync that cygwin has ported is within standards then there is no rsync reason this problem should happen.

I've asked the cygwin support site if they know of any issues and they have yet to reply.

So, my question is whether the version of rsync that is ported to cygwin is standard. If so, is there any reason cygwin & rsync keep failing like this?

I've asked the local rsync on linux guru's and they can't see any reason this should fail from a linux perspective. Apparently I am our company cygwin knowledge base by default.

Looking for some help or guidance. Your time and consideration are appreciated.

Blaine Miller

kbp 06-09-2011 06:08 PM

Have you tried increasing verbosity? .. maybe 3 '-v's

John VV 06-09-2011 06:17 PM

well you are running this "Windows server 2003R2 Standard Edition"
so have you asked your Microsoft support ?

you are also running this NOT FREE -- RHEL4.5 and RHEL4.7
( the current is RHEL4.9 )
so you DO HAVE A paid for red hat support contract -- right ?--

have you asked red hat ?

blainemiller 06-10-2011 12:37 PM

Hello, John VV,

Microsoft says they don't provide support for cygwin. Only Microsoft products. Microsoft Windows Server 2003R2 Standard edition seems to be running fine.

Red Hat says they don't provide support for cygwin. Only Red Hat products. Red Hat 4.5 and Red Hat 4.7 seem to be running fine. The versions of rsync on both of these platforms seem to be running fine. rsync between linux hosts works fine.

cygwin finally responded to my request for support. cygwin states that the port of rsync for cygwin is "flakey" and doesn't always work. That sometimes it fails for no apparent reason. cygwin suggests I use an alternative product like Windows Services For UNIX, sfu, or some other alternative product. I'm looking in to these alternatives now.

I'm going to mark this as solved. Thank you very much for your time and consideration. Thanks to all those who viewed this question as well.

Blaine Miller

All times are GMT -5. The time now is 04:01 AM.