LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 06-18-2013, 03:14 PM   #31
lleb
Senior Member
 
Registered: Dec 2005
Location: Florida
Distribution: CentOS/Fedora
Posts: 2,671

Rep: Reputation: 503Reputation: 503Reputation: 503Reputation: 503Reputation: 503Reputation: 503

Quote:
Originally Posted by frsechet View Post
Still no.
Following what I think is the problem (something to do with rsync on the remote server because Synology modified it somehow, and not ssh), I found this. It didn't work (I still need to enter a 2nd password), but it seems to confirm that there is a password needed for using the rsync module, which has nothing to do with ssh.
did you bother fixing your permissions? if not then you still have the same problem. you have the wrong permissions on your private rsa key.
 
Old 06-18-2013, 03:22 PM   #32
frsechet
Member
 
Registered: May 2013
Posts: 32

Original Poster
Rep: Reputation: Disabled
Yes, of course! Sorry I wasn't clear. I fixed the permissions, but it didn't change anything.
 
Old 06-18-2013, 03:38 PM   #33
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 4,213

Rep: Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614
what do you get if you:

rsync -vvvvvvarh as parameters?

What about specifying your key?

rsync -vvvvvarh -e "ssh -i /home/user/.ssh/id_key"

Last edited by szboardstretcher; 06-18-2013 at 03:40 PM.
 
Old 06-18-2013, 07:09 PM   #34
frsechet
Member
 
Registered: May 2013
Posts: 32

Original Poster
Rep: Reputation: Disabled
Hi guys,

I really do appreciate all your help, really.
I know you all *know* for absolutely sure that this is a problem with my ssh key, but could you just imagine for a second that, maybe, this has nothing to do with my key? My key is fine, really. When I ssh directly, it works. When I rsync with -vvvvvarh, I do get a lot of text, and it says that the host is known, that it accepts the key, that all is fine. OK. Then, after that, after I'm SSHed into the remote server, it asks another time for the root password. This is the password I'm stuck at. I know the password, I just don't want to have to enter it (for cronjobs, not just out of lazyness!).

Now just imagine that this problem has nothing to do with the rsa key. What if the manufacturer of the remote server, which is a Synology NAS, has modified the system, so that rsyncing to that NAS requires a root password? For some reason rsync seems to be treated as a module that requires a root password in order to get accessed, even when you are SSHing with a user that is not root and that has a different password.

In other words, let's say I'm trying to rsync with "user", with password "pwd1". Let's also say that "root" has a password "pwdroot"
If I rsync with this user, the system will ask me for that user's password on the remote server, so I enter "pwd1". Then, it asks for a second password, where I need to enter "pwdroot".
If I setup a key for this user (I've done that), the system will skip the first password, which is basically the "SSH into remote server" step. BUT it will then still ask for the root password afterwards, and this has nothing to do with the rsa key that you seem to be very convinced is the root (a little pun intended) of my problem here! :-)

I'm not trying to be rude or anything, I do appreciate your help a lot. I'm just trying to get you guys on a different road that seems more plausible. I'm not stuck with creating a RSA key, I'm stuck *after* said key is accepted by the remote server.
Can you think of a different view on this problem that is not RSA related? Perhaps something I need to do on the remote server?

Thanks all for your precious help. Again, I'm not trying to be rude, I'm just saying that it is very unlikely that this second password has anything to do with the RSA key that I (apparently correctly) setup earlier!

:-)
 
Old 06-19-2013, 09:21 AM   #35
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 4,213

Rep: Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614
No problem.

How about the contents of the rsyncd.conf file on that NAS?
 
Old 06-19-2013, 09:27 AM   #36
frsechet
Member
 
Registered: May 2013
Posts: 32

Original Poster
Rep: Reputation: Disabled
Alright, here we go:
Code:
#motd file = /etc/rsyncd.motd
#log file = /var/log/rsyncd.log
pid file = /var/run/rsyncd.pid
lock file = /var/run/rsync.lock
use chroot = no
[NetBackup]
path = /var/services/NetBackup
comment = Network Backup Share
uid = root
gid = root
read only = no
list = yes
charset = utf-8
auth users = root
secrets file = /etc/rsyncd.secrets
 
Old 06-19-2013, 09:30 AM   #37
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 4,213

Rep: Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614
yeah. for testing reasons,.. i would totally comment out everything from [Netbackup] to the end and try again.
 
Old 06-19-2013, 09:33 AM   #38
frsechet
Member
 
Registered: May 2013
Posts: 32

Original Poster
Rep: Reputation: Disabled
Including [Netbackup]? (Does it need a reboot afterwards?)
 
Old 06-19-2013, 09:37 AM   #39
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 4,213

Rep: Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614
Yes, including [netbackup]. Thats what from here to here means,. inclusive.

Try without rebooting. Make sure rsyncd isnt running first. It should start up new at every connection.
 
Old 06-19-2013, 09:51 AM   #40
sundialsvcs
LQ Guru
 
Registered: Feb 2004
Location: SE Tennessee, USA
Distribution: Gentoo, LFS
Posts: 9,078
Blog Entries: 4

Rep: Reputation: 3173Reputation: 3173Reputation: 3173Reputation: 3173Reputation: 3173Reputation: 3173Reputation: 3173Reputation: 3173Reputation: 3173Reputation: 3173Reputation: 3173
Are you running an "ssh-agent?"
 
Old 06-19-2013, 09:51 AM   #41
frsechet
Member
 
Registered: May 2013
Posts: 32

Original Poster
Rep: Reputation: Disabled
Just making sure! :-) - because either way, it didn't help!

@sundialsvcs: not that I'm aware of.

Last edited by frsechet; 06-19-2013 at 09:52 AM.
 
Old 06-19-2013, 10:04 AM   #42
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 4,213

Rep: Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614Reputation: 1614
Bummer.

At this point, when mucking around with config and parameters doesnt pan out, i break out 'strace' and 'gdb' to see what the hell its doing and where its getting its screwy ideas from.

Good luck!
 
Old 10-01-2014, 09:38 AM   #43
Wouter78
LQ Newbie
 
Registered: Oct 2014
Posts: 2

Rep: Reputation: Disabled
Exact same problem

Hi,

Did you ever get this to work? I'm experiencing the exact same problem. I think it has something to do with special access limitation of Synology NetBackup folder.

Regards,
Wouter
 
Old 10-01-2014, 09:46 AM   #44
frsechet
Member
 
Registered: May 2013
Posts: 32

Original Poster
Rep: Reputation: Disabled
Oh, yes, I did. But I really can't recall what the issue was... I think I had to specify the correct absolute path and not directly the ::NetBackup directory in order to get it to work.

So
Code:
remote_IP::NetBackup/whatever/folder
had to turn into
Code:
:/volume1/NetBackup/whatever/folder
Note the ":/" part at the beginning (not "::") and also that it is case sensitive.
Hope this helps...
 
Old 10-01-2014, 09:56 AM   #45
Wouter78
LQ Newbie
 
Registered: Oct 2014
Posts: 2

Rep: Reputation: Disabled
That's it. Thanks a lot!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Passwordless ssh works. Normal login/ssh Fails. gurunarayanan Linux - Newbie 9 11-08-2012 05:42 AM
[SOLVED] rsync fails in cron - ssh key prob for rsync? jonathansfl Linux - Server 6 12-09-2010 10:48 AM
Passwordless SSH works... but not with a command Zxian Linux - Networking 5 05-23-2008 04:59 PM
ssh keeps asking for password, have set up passwordless gorbgorb Linux - Networking 4 03-21-2007 05:24 PM
passwordless SSH works for root but not www-data zovres Linux - General 1 07-26-2006 12:31 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 04:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration