LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 04-11-2010, 12:44 PM   #1
athreyavc
Member
 
Registered: May 2004
Location: bangalore
Distribution: Cent OS, Ubuntu
Posts: 116

Rep: Reputation: 15
RHEL 5.1 after installing mod_ssl, httpd server wont start


Hi All,

I am trying to do a https access with virtual hosting with apache.

But when I install mod_ssl rpm httpd server does not start again

I am stumped

httpd -t shows syntax is OK

Regards,

Athreya
 
Old 04-11-2010, 12:59 PM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,768

Rep: Reputation: 1843Reputation: 1843Reputation: 1843Reputation: 1843Reputation: 1843Reputation: 1843Reputation: 1843Reputation: 1843Reputation: 1843Reputation: 1843Reputation: 1843
Hi,

You should check the apache error_log for hints.

Regards
 
Old 04-11-2010, 04:21 PM   #3
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,824

Rep: Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615
Are you going to post the error message / logs or just not help us help you?
 
Old 04-11-2010, 06:33 PM   #4
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,502

Rep: Reputation: 2617Reputation: 2617Reputation: 2617Reputation: 2617Reputation: 2617Reputation: 2617Reputation: 2617Reputation: 2617Reputation: 2617Reputation: 2617Reputation: 2617
also why have you not ran
Code:
yum update
to get the system up to date .The current is RHEL 5.4
 
Old 04-11-2010, 09:13 PM   #5
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,824

Rep: Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615Reputation: 615
Quote:
Originally Posted by John VV View Post
The current is RHEL 5.4
5.5 as of a week or two ago
 
Old 04-11-2010, 10:52 PM   #6
athreyavc
Member
 
Registered: May 2004
Location: bangalore
Distribution: Cent OS, Ubuntu
Posts: 116

Original Poster
Rep: Reputation: 15
Thanks all for the reply.

I got the solution. I was configuring httpd.conf with ssl, But the key and certs were wrong. Also, I was not sure about how to add the correct key and cert.

http://www.linuxtopia.org/online_boo...re-server.html

I followed this link and I am fine now.

Please considre this quetsion as closed

Regards,
Athreya
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't start httpd server on fedora core 5 pompadir Linux - Server 8 05-30-2007 04:09 AM
httpd - mod_ssl - Virtualhost netforce_nl Linux - Server 4 10-31-2006 03:32 PM
httpd wont start brunog Linux - Software 11 10-09-2006 04:52 PM
mod_ssl for httpd 2.x ? dominant Linux - Security 2 11-02-2004 02:43 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 03:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration