-   Linux - Server (
-   -   Recreate a Raid5 MD0 into a Raid5 MD3 (

CADIT 01-09-2010 11:49 AM

Recreate a Raid5 MD0 into a Raid5 MD3
I have no drive failures but just need to recreate a raid5 set as the next free MD disk number.
Originally I built a temp OS of debian on a single drive and had 4x2TB drives in a raid5 software array (MD0) this worked fine and allowed me to move all data to it, and remove our old fileserver.
I have now pulled out the 4 x 2TB Raid 5 drives and created a new OS on two new 80GB drives, partioned as follows,
MD0 is now 250mb Raid1 as /boot
MD1 is 4GB Raid1 Swap
MD2 is 76GB Raid1 as /

If I turn off and push back in the 4x2TB drives I cannot see a MD3. I presume I would need to create a MD3 from these 4 drives but I dont want to mess things up as its live data. So im here asking for help, or a bit of hand holding to get it done right.

As I say no drives have failed so hopefully it should be a simple process.

PS - Its a Debian Lenny 5.0.3 Raid1 fresh install replacing a Debian Lenny 5.0.3 on a single disk.

jlinkels 01-10-2010 08:55 PM

You might try to add a line to mdadm.conf which contains the same information as the previous mdadm.conf on the 4x2TB system. On the 4x2 system you had a line which described md0 with UUID's and all. You should add this line to the current mdadm.conf, but this time change md0 to md3.


CADIT 01-11-2010 04:46 AM

Worked a treat!
Thanks jlinkels, got the old array definition details from the old mdadm.conf file, and copied it into the new mdadm.conf file. Then changed /dev/md0 to /dev/md3 and rebooted. It picked up the array and I just had to mount it.
Thanks again for you help

All times are GMT -5. The time now is 09:00 PM.