-   Linux - Server (
-   -   reading cifs share fails with permission denied (

scott8035 06-15-2011 01:15 PM

reading cifs share fails with permission denied
I'm trying to setup a samba server to share data among clients via cifs. As a test, I mounted the samba share on the same machine and tried to access the contents of the directory. The mount command was:

mount -t cifs -o username=sthomaso,workgroup=WORKGROUP //server/scratch /mnt/server/scratch

...which worked fine after entering the password. Although I can "cd /mnt/server/scratch", when I try to list the contents of the directory with "ls", I get error "ls: reading directory .: Permission denied".

On the server, my /etc/samba/smb.conf is:

security = user
workgroup = WORKGROUP

writeable = yes

path = /var/scratch
valid users = @feausers
writeable = yes

User "sthomaso" was added to tdbsam with command:

pdbedit -a -u sthomaso

User "sthomaso" is in group "feausers", verified with the "groups sthomaso" command.

"/bin/ls -lF /var | grep scratch" shows:

drwxrwx--T. 2 root feausers 4096 Jun 14 14:40 scratch/

/var/log/samba/log.smbd contains validation of a successful connection in line:

<snip> smbd/service.c:1070(make_connection_snum)
<snip> connect to service scratch initially as user sthomaso (uid=500, gid=501) (pid 99999)

So it looks like I am successfully mounting the share, but why can't I read the directory and access the files?

scott8035 06-15-2011 01:28 PM

Forgot to mention...this is RHEL 6.1

scott8035 06-16-2011 08:40 PM

FYI, I got some help from Red Hat...the problem was SELinux restricting permissions. I don't need the control offered by SELinux, so I just disabled it by editing /etc/selinux/config and restarting.

All times are GMT -5. The time now is 12:41 PM.