LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 12-27-2010, 07:15 PM   #1
bombshell
LQ Newbie
 
Registered: Dec 2010
Distribution: Fedora 14, Ubuntu 10.10, OpenSUSE 11.3
Posts: 13

Rep: Reputation: 0
Red face pwauth is not working properly under Apache


I have http://code.google.com/p/pwauth/ downloaded and compiled and installed at /usr/local/libexec/pwauth. I have tested in CLI in a regular account and it excuted successfully but when it comes getting it to work under Apache. It just exits with status code 1 which including to the documentation indicates STATUS_UKNOWN.

PHP Code:
exec'echo -e \'bombshell\nhu4_=_Usw*masaz\' | /usr/local/libexec/pwauth' $output $return );

var_dump$return ); 
Code:
echo -e 'bombshell\nhu4_=_Usw*masaz' | /usr/local/libexec/pwauth
I notice even when I 'su apache', the command still fails without any reason. I've reviewed every log that might show errors but non are informative.

My purpose is get MediaWiki to authenticate via System users using this extension: http://www.mediawiki.org/wiki/Extension:PwAuthPlugin.

Any ideas, anything I might be missing? I've been google'in for alternatives but I can't find what I need for my particular setup.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I think my apache is not setup properly shadiadiph Linux - Server 4 07-05-2009 10:12 PM
why does my apache server cannot work properly!! kewei Linux - Server 2 12-18-2008 04:33 PM
X not working properly. MylesCLin Linux - Software 1 09-15-2004 11:46 AM
properly using Userdir apache 2.0 spoody_goon Linux - Networking 0 05-11-2004 10:29 AM
apache or php doesn't work properly on RH8.0 abd_bela Linux - Networking 6 03-18-2003 06:20 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 12:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration