LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (https://www.linuxquestions.org/questions/linux-server-73/)
-   -   PuTTY - Disconnected: No Supported Authentication methods available (https://www.linuxquestions.org/questions/linux-server-73/putty-disconnected-no-supported-authentication-methods-available-4175519198/)

dandelion 09-17-2014 02:15 PM

PuTTY - Disconnected: No Supported Authentication methods available
 
I am hosting a KVM server with CentOS 6.5 through Vultr.com, the server was working fine about 1-2 hours ago but now when I try to login via PuTTY I get the error "PuTTY - Disconnected: No Supported Authentication methods available (server sent: publickey,gssapi-keyex,gssapi-with-mic)". I can still login to the server from the Vultr.com web console and run any commands needed that might fix this if someone has a suggestion.. I have never used publickeys on this server at all so I am not sure why these errors are just randomly popping up.. Anyone have ideas?

Thanks!

dandelion 09-17-2014 04:42 PM

Fixed
 
Alright, not sure why this problem even happened in the first place but I figured out how to fix it in my case. I used the web console and removed and re-installed ssh by running "yum erase openssh-server" and then "yum install openssh-server"

unSpawn 09-17-2014 05:35 PM

Quote:

Originally Posted by dandelion (Post 5239937)
I (..) removed and re-installed ssh by running "yum erase openssh-server" and then "yum install openssh-server"

With Linux it is extremely rare to have to remove and reinstall software. That is more of a Microsoft-like approach. More importantly it teaches you nothing with respect to troubleshooting like checking application arguments, ownership, configuration, checking log file entries for errors, etc, etc. I would suggest next time you take the time to build up your practical Linux knowledge. It's worth it.

dandelion 09-17-2014 05:37 PM

Well if anyone else has other suggestions for why this would happen so I could avoid it from happening again I would love to learn. I googled the error message for about 2 hours before I made this thread and they were all related to incorrect public keys, which is totally unrelated seeing as I don't use a public key to login currently.

Vivekanandan Dhamodharan 11-12-2016 04:48 AM

solution
 
Now you try to Normal login in your system. Then edit to using vi /etc/ssh/sshd_config key press town now you check the PasswordAuthentication yes save and restart the service sshd.

TB0ne 11-15-2016 09:30 AM

Quote:

Originally Posted by Vivekanandan Dhamodharan (Post 5629663)
Now you try to Normal login in your system. Then edit to using vi /etc/ssh/sshd_config key press town now you check the PasswordAuthentication yes save and restart the service sshd.

Please, don't re open old threads..this was closed for TWO YEARS before you re-opened it.

zopfan 03-25-2019 05:52 AM

Quote:

Originally Posted by dandelion (Post 5239856)
I am hosting a KVM server with CentOS 6.5 through Vultr.com, the server was working fine about 1-2 hours ago but now when I try to login via PuTTY I get the error "PuTTY - Disconnected: No Supported Authentication methods available (server sent: publickey,gssapi-keyex,gssapi-with-mic)". I can still login to the server from the Vultr.com web console and run any commands needed that might fix this if someone has a suggestion.. I have never used publickeys on this server at all so I am not sure why these errors are just randomly popping up.. Anyone have ideas?

Thanks!

Diff from all other answers here:

I received this authentication error- No supported authentication methods available (server sent: publickey) repeatedly while connecting to my google cloud platform and connecting thru FileZilla, even when I had spent hours checking my each of my steps again and again by watching diff youtube videos and reading articles over Digital Ocean and similar.

But finally succeeded in a second, when I went into GCloud> Desired Project> Compute Engine> Metadata (in the left bar)> Metadata (in the main Pane)> and there I changed ' enable-oslogin' from 'True' to 'False'.

I had, sometime in my overzeal, had put in this key yesterday while doing something else.


All times are GMT -5. The time now is 02:17 AM.