LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 04-13-2012, 02:51 PM   #1
vahab
Member
 
Registered: Jun 2011
Posts: 58

Rep: Reputation: Disabled
pure-ftpwho doesn't work in pure-ftpd


Hi,

I have installed pure-ftpd v1.0.29 on RHEL 5.5 with default configurations.
I created a linux account and a pure-ftp account.
I am able to connect to FTP service from local machine or remote machines.
The problem is when I run pure-ftpwho it shows a blank output as below while I have an active session from a remote machine.

# pure-ftpwho

+------+---------+-------+------+-------------------------------------------+
| PID | Login |For/Spd| What | File/IP |
+------+---------+-------+------+-------------------------------------------+

However it generates output and shows ftp session only if I connect to ftp service from my local machine.

I was wondering if anyone could tell me what is wrong.

Thanks.
 
Old 04-13-2012, 04:58 PM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,384

Rep: Reputation: 1722Reputation: 1722Reputation: 1722Reputation: 1722Reputation: 1722Reputation: 1722Reputation: 1722Reputation: 1722Reputation: 1722Reputation: 1722Reputation: 1722
Hi,

Quote:
I created a linux account and a pure-ftp account.
What you mean by that? Unless you want to use virtual users there is no need to create a "pure-ftp account".

Regarding pure-ftpwho behavior, it's indeed strange as it should show connections regardless of the connecting IP.
Since you're using RHEL, the only thing that comes in mind is SELinux. Try to disable it temporarily and see if pure-ftpwho works as expected.

Regards
 
Old 04-14-2012, 03:23 AM   #3
vahab
Member
 
Registered: Jun 2011
Posts: 58

Original Poster
Rep: Reputation: Disabled
Yes, I am using virtual users. (I couldn't get it working without virtual users anyway)

SELinux is disabled on my machine.
I reinstalled pure-ftpd and result is the same .Here is my configuration :

# cat pure-ftpd.conf | egrep -v "^#|^$"
ChrootEveryone yes
BrokenClientsCompatibility no
MaxClientsNumber 50
Daemonize yes
MaxClientsPerIP 8
VerboseLog no
DisplayDotFiles yes
AnonymousOnly no
NoAnonymous no
SyslogFacility ftp
DontResolve yes
MaxIdleTime 15
PureDB /etc/pure-ftpd/pureftpd.pdb
PAMAuthentication yes
LimitRecursion 10000 8
AnonymousCanCreateDirs no
MaxLoad 4
AntiWarez yes
Umask 133:022
MinUID 500
UseFtpUsers no
AllowUserFXP no
AllowAnonymousFXP no
ProhibitDotFilesWrite no
ProhibitDotFilesRead no
AutoRename no
AnonymousCantUpload yes
AltLog clf:/var/log/pureftpd.log
MaxDiskUsage 99
CustomerProof yes
#
 
Old 04-14-2012, 05:13 AM   #4
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,384

Rep: Reputation: 1722Reputation: 1722Reputation: 1722Reputation: 1722Reputation: 1722Reputation: 1722Reputation: 1722Reputation: 1722Reputation: 1722Reputation: 1722Reputation: 1722
Hi,

Hmm your config looks good.
Maybe you can stop using pam authentication and see if it's starts logging both local and remote connections. I don't see any other reason why it shouldn't show remote connections.

Regards
 
Old 04-14-2012, 06:36 AM   #5
vahab
Member
 
Registered: Jun 2011
Posts: 58

Original Poster
Rep: Reputation: Disabled
Setting "PAMAuthentication no" and restarting the service didn't help either
 
Old 04-14-2012, 09:10 AM   #6
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,384

Rep: Reputation: 1722Reputation: 1722Reputation: 1722Reputation: 1722Reputation: 1722Reputation: 1722Reputation: 1722Reputation: 1722Reputation: 1722Reputation: 1722Reputation: 1722
Try pure-ftpwho -n or pure-ftpwho -H, so it doesn't resolve the remore host IP and see if it helps.
If not, better contact the pure-ftpd maintainer as you maybe hit a bug.

Regards
 
1 members found this post helpful.
Old 04-14-2012, 03:25 PM   #7
vahab
Member
 
Registered: Jun 2011
Posts: 58

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by bathory View Post
Try pure-ftpwho -n or pure-ftpwho -H, so it doesn't resolve the remore host IP and see if it helps.
Yes ! Both -n and -H solve the issue

Although I think this is a strange behavior for pure-ftpd to generate a null output quickly when it is unable to resolve the IP to name.

Thank you so much for your help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Pure-authd not passing variables to pure-ftpd welshdemon Linux - Software 1 02-11-2011 05:47 PM
Problems getting Pure-ftpd/Pureadmin to work... gregoryj42 Linux - Newbie 0 02-08-2009 03:03 PM
pure-ftpd-mysql activates pure-ftpd zvikamer Linux - Software 2 03-01-2008 01:11 PM
pure-ftpd roofy Linux - Software 6 03-05-2007 05:06 AM
Pure-ftpd Yoinx Linux - Software 0 10-18-2004 01:12 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 01:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration