LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 02-20-2010, 09:18 AM   #1
johnh10000
Member
 
Registered: Nov 2008
Distribution: Ubuntu Lucid Lynx
Posts: 541

Rep: Reputation: 33
proftpd and passive ports?


I have a problem which I think is todo with passive ports. Basically I get a directory listing on the box where it's running. If I go onto the world visible, domain, it logs in but no dir listing

Using firestarter now. Asked it to open relivant ports. told proftpd to use relivant ports. Check with shields up. no problem on ports 20-21 but no passive ports how do I fix this please. I have screenshot of firestarter. the errors and the conf file.

Last edited by johnh10000; 10-31-2010 at 05:49 AM.
 
Old 02-20-2010, 09:42 AM   #2
smoker
Senior Member
 
Registered: Oct 2004
Distribution: Fedora Core 4, 12, 13, 14, 15, 17
Posts: 2,279

Rep: Reputation: 249Reputation: 249Reputation: 249
Allow connections from host ?
All those are local addresses. How do you allow connections from the world ?
 
Old 02-20-2010, 09:49 AM   #3
johnh10000
Member
 
Registered: Nov 2008
Distribution: Ubuntu Lucid Lynx
Posts: 541

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by smoker View Post
Allow connections from host ?
All those are local addresses. How do you allow connections from the world ?
well thats probably my problem. if your reffering to the firewall, screen. I am allowing 20-21 and the passive ports in from anywhere.

Last edited by johnh10000; 02-20-2010 at 09:55 AM.
 
Old 02-20-2010, 09:56 AM   #4
smoker
Senior Member
 
Registered: Oct 2004
Distribution: Fedora Core 4, 12, 13, 14, 15, 17
Posts: 2,279

Rep: Reputation: 249Reputation: 249Reputation: 249
Sorry I just read the docs. If you have Allow service listed for ftp then it should work.
The Allow connections from host actually allows any type of connection from host.
Allow service is just the service listed and who can access it.

They are separate rules.

do you have to enable outbound connections for passive to work ?
Do you have a router with the passive ports opened ?
 
Old 02-20-2010, 10:08 AM   #5
johnh10000
Member
 
Registered: Nov 2008
Distribution: Ubuntu Lucid Lynx
Posts: 541

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by smoker View Post
Sorry I just read the docs. If you have Allow service listed for ftp then it should work.
The Allow connections from host actually allows any type of connection from host.
Allow service is just the service listed and who can access it.

They are separate rules.

do you have to enable outbound connections for passive to work ?
Do you have a router with the passive ports opened ?
GOOD POINT on the firewall gotem one way but not the other. I know there open on the router both ways. I'll try that now.
 
Old 02-20-2010, 10:13 AM   #6
johnh10000
Member
 
Registered: Nov 2008
Distribution: Ubuntu Lucid Lynx
Posts: 541

Original Poster
Rep: Reputation: 33
Bad news on that front I have permissive by default. so yeah they are. and the router is set to udp/tcp 10100-10199 192.168.1.3

so it ait that either
 
Old 02-20-2010, 10:24 AM   #7
smoker
Senior Member
 
Registered: Oct 2004
Distribution: Fedora Core 4, 12, 13, 14, 15, 17
Posts: 2,279

Rep: Reputation: 249Reputation: 249Reputation: 249
Hmmm,
It definitely hangs after passive is started...

Have your tried using the original ports in your proftpd.conf ?
# PassivePorts 49152 65534

It seems to work fine if I turn off passive at my end.

Maybe virgin are blocking higher ports ?

This is informative,
http://www.ncftp.com/ncftpd/doc/misc...rewallProblems
but your logs seem ok regarding the ip address.

Last edited by smoker; 02-20-2010 at 10:39 AM.
 
Old 02-20-2010, 10:37 AM   #8
johnh10000
Member
 
Registered: Nov 2008
Distribution: Ubuntu Lucid Lynx
Posts: 541

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by smoker View Post
Hmmm,
It definitely hangs after passive is started...

Have your tried using the original ports in your proftpd.conf ?
# PassivePorts 49152 65534

It seems to work fine if I turn off passive at my end.
no but thats intresting. you get dir listing download something the lot?

oh what client did ya use.

wait a bit, and I'll post back in here when I moved the ports.
 
Old 02-20-2010, 10:51 AM   #9
smoker
Senior Member
 
Registered: Oct 2004
Distribution: Fedora Core 4, 12, 13, 14, 15, 17
Posts: 2,279

Rep: Reputation: 249Reputation: 249Reputation: 249
I got a listing ok. I didn't download anything, thought it would be rude to ...
Using gFTP in Fedora.
 
Old 02-20-2010, 10:51 AM   #10
johnh10000
Member
 
Registered: Nov 2008
Distribution: Ubuntu Lucid Lynx
Posts: 541

Original Poster
Rep: Reputation: 33
Chers mate. You have your thanks. MAking me change the ports on the router, got me to find it. the upnp switch had become pressed on al is fine with theworld her again.

chhers
 
Old 02-20-2010, 10:55 AM   #11
smoker
Senior Member
 
Registered: Oct 2004
Distribution: Fedora Core 4, 12, 13, 14, 15, 17
Posts: 2,279

Rep: Reputation: 249Reputation: 249Reputation: 249
No worries.
You realise I can see into the private dir ?
 
Old 02-20-2010, 10:58 AM   #12
johnh10000
Member
 
Registered: Nov 2008
Distribution: Ubuntu Lucid Lynx
Posts: 541

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by smoker View Post
No worries.
You realise I can see into the private dir ?
I do it won't be there shortly. It was only there for when the webcam lived on the box next to the webserver
 
Old 02-20-2010, 11:01 AM   #13
johnh10000
Member
 
Registered: Nov 2008
Distribution: Ubuntu Lucid Lynx
Posts: 541

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by smoker View Post
I got a listing ok. I didn't download anything, thought it would be rude to ...
Using gFTP in Fedora.
ah fedora, I am trying that too on another network box. just added gnome. now how the heck do i add/remove programs with the provided utility, when there arre no repos in it !!! ?

thanks for your help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ProFTPd, Redhat 8.0 and passive mode Slasher Linux - Networking 10 05-09-2008 04:08 PM
proftpd timing out with passive ToothlessRebel Linux - Server 1 03-18-2007 11:06 AM
proftpd passive state gabsik Linux - Networking 0 09-26-2006 07:25 AM
Proftpd passive connections gabsik Linux - Networking 5 06-18-2006 06:18 AM
proftpd, passive mode, and a router.... apberzerk Linux - Networking 2 07-11-2004 07:05 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 06:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration