-   Linux - Server (
-   -   Problems installing ffmpeg (

sokar24 01-03-2009 08:09 AM

Problems installing ffmpeg
I have been busy for 4 days now getting ffmpeg + codecs get to work correctly. I am running mediasharesuite and need this along with MEncoder etc. to decode/encode movies on my site.

Iam running an almost (with 4 sites total) dedicated server box

Specifications are:
- Fedora core 8 32 bit
- yum rpmfusion-free.repo (and freshrpm's but that's disabled for now)

The site says I need:

A Linux server (Fedora Core, CentOS, Ubuntu, Slackware or SuSE).
Web server, Apache (with CGI-BIN access, MOD_REWRITE enabled).
MySQL 4.1 or higher
PHP 4.3 or higher
GD Library 2 installed in PHP, with support for FreeType fonts.
Mencoder and Mplayer (
AMR codec support (
AC3 codec support (
AAC codec support (
MP3 codec support (
OGG/Vorbis codec support (
x264 codec support (
DivX/XviD codec support (
win32 codec support (
FLVtool2 (
ffmpeg-php (optional)
Ability to run PHP from the command line (CLI) using exec()
Ability to execute background processes with exec("binary > /dev/null &")
Recommended PHP Configuration
safe_mode = off
max_execution_time = 9000 (recommended, to prevent timeouts during video upload/conversion)
session.gc_maxlifetime = 14000 (recommended, to prevent session expires during video upload)
open_basedir = (no value)
output_buffering = 4096
upload_max_filesize = 200M (recommended maximum video upload size in MB)
post_max_size = 200M (recommended maximum video upload size in MB)
max_input_time = 9000; (to allow PHP to upload large video files and images and avoid upload errors in PHP versions >=5.1.3 - PHP Bug #37306)
magic_quotes_gpc = On (so not to have errors in data posted that may include quote characters)
magic_quotes_runtime = Off (for security reasons)
register_argc_argv = On (for pages using post data)
register_globals = Off (for security reasons)

- Recommended php settings are already loaded

I tried to install ffmpeg with yum but mediasharesuite keeps saying that it cant find anything. What is the default install dir btw? And if I try running it via ssh command line this comes up:

ffmpeg: error while loading shared libraries: cannot open shared object file: No such file or directory

Also tried installing everything manually or with the script from sherin but it fails at the mplayer installing, something about a non existing folder?!

The last problem I have is that mediashare suite keeps saying i have openbasedir disabled, although its disabled?!

And btw, I do not only need it for this site, my customers want ffmpeg 2 :)

Anyone knows a good autoinstall script or fix for my probs??

Thanks in advance

pddm 01-05-2009 06:01 PM

Are you sure ffmpeg is not yet installed?
Try to locate it.

locate ffmpeg
Default could be /usr/bin/ffmpeg and/or /usr/local/bin/ffmpeg

You can always install from source from the ffmpeg home page

Your errors with libavcodec could also be caused by using the wrong path to it or not having the right permissions set.

All times are GMT -5. The time now is 06:56 PM.