LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 07-17-2008, 09:20 AM   #1
guillermo
LQ Newbie
 
Registered: Aug 2007
Location: Argentina
Posts: 25

Rep: Reputation: 15
problem with mkfs.ext3


Hello;

im having troubles making a filesystem in a partition, for third time in a row when i execute mkfs.ext3 /dev/sdb1 the proccess goes into a sleep mode and hangs here, even if a kill the pid the process it keep the same status.

Quote:

[root@server ~]# mkfs.ext3 /dev/sdb1
mke2fs 1.35 (28-Feb-2004)
Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
12222464 inodes, 24412767 blocks
1220638 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=25165824
746 block groups
32768 blocks per group, 32768 fragments per group
16384 inodes per group
Superblock backups stored on blocks:
32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,
4096000, 7962624, 11239424, 20480000, 23887872

Writing inode tables: 1/746
process state:

[root@server1 ~]# ps axl | grep D
F UID PID PPID PRI NI VSZ RSS WCHAN STAT TTY TIME COMMAND

4 0 22134 21184 18 0 8340 5292 blk_co D+ pts/4 0:00 mkfs.ext3 /dev/sdb1


Any tips or ideas , about whats going on will be very thanksfully

Regards!
 
Old 07-17-2008, 09:41 AM   #2
Okie
Senior Member
 
Registered: Mar 2002
Location: Oklahoma
Posts: 1,154

Rep: Reputation: 186Reputation: 186
you know you are not supposed to do that on a mounted disk partition?

umount it first, then try:

mkfs.ext3 /dev/sdb1

or

mke2fs -j /dev/sdb1
 
Old 07-17-2008, 09:48 AM   #3
kilgoretrout
Senior Member
 
Registered: Oct 2003
Posts: 2,740

Rep: Reputation: 262Reputation: 262Reputation: 262
Make sure sdb1 is not mounted when you run that command.

Oops!! Beat me to it. Great minds think alike.

Last edited by kilgoretrout; 07-17-2008 at 09:49 AM.
 
Old 07-17-2008, 10:28 AM   #4
guillermo
LQ Newbie
 
Registered: Aug 2007
Location: Argentina
Posts: 25

Original Poster
Rep: Reputation: 15
I posted the problem in other forum with other details and the solution; here is it:

http://www.linuxforums.org/forum/red...tml#post608040

Thanks everybody for the help!.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Testdisk help, stupid mkfs.ext3... Apt Quadruped Linux - Desktop 2 07-12-2008 02:31 PM
ext3 super block get modified after mkfs.ext3 amitpardesi Programming 1 04-25-2008 10:42 AM
HELP: QTparted says There was a problem with mkfs.ext3 dhruba.bandopadhyay Linux - General 2 06-14-2006 10:27 AM
mkfs.ext3 nearly stops at about 61% of blocks ejkeebler Linux - Newbie 1 04-27-2006 06:23 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 04:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration