LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 12-04-2007, 09:04 AM   #1
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,679

Rep: Reputation: 55
Problem on starting webmin and usermin


Hi folks,

Ubuntu 7.04 server amd64 (Host OS)
VMWare
CentOS 5 (Guest OS)


Webmin and Usermin are running on Ubuntu. I can't start Webmin and Usermin on Firefox by running;

https://localhost:10000
https://localhost:20000

I must run;
https://domain.com:10000
https://domain.com:20000

to start them.


On console
$ sudo /etc/init.d/webmin restart
Code:
Password:
Stopping Webmin server in /usr/share/webmin
Starting Webmin server in /usr/share/webmin
Webmin doesn't start


$ sudo /etc/init.d/usermin restart
Code:
Stopping Usermin server in /usr/share/usermin
Starting Usermin server in /usr/share/usermin
Usermin doesn't start


Please help. TIA


satimis
 
Old 12-04-2007, 10:02 AM   #2
camorri
LQ Veteran
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2, current, slackware-arm-currnet
Posts: 5,478

Rep: Reputation: 632Reputation: 632Reputation: 632Reputation: 632Reputation: 632Reputation: 632
Two things come to mind, first of all do you have webmind running? From a konsole, verify it is there with the command 'ps aux | grep webmind' ( without the quotes ).

Second, do you have an entry in your /etc/hosts file for 'localhost 127.0.0.1' ? If not add it, and retry.
 
Old 12-04-2007, 10:53 AM   #3
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,679

Original Poster
Rep: Reputation: 55
Quote:
Originally Posted by camorri View Post
Two things come to mind, first of all do you have webmind running? From a konsole, verify it is there with the command 'ps aux | grep webmind' ( without the quotes ).
Thanks for your advice.


$ ps aux | grep webmin
Code:
root      5270  0.0  0.2  61348  9672 ?        Ss   Dec04   0:00 /usr/bin/perl /usr/share/webmin/miniserv.pl /etc/webmin/miniserv.conf
satimis   5846  0.0  0.0   5028   836 pts/0    S+   00:55   0:00 grep webmin
$ ps aux | grep usermin
Code:
root      5674  0.0  0.2  51764  8196 ?        Ss   Dec04   0:00 /usr/bin/perl /usr/share/usermin/miniserv.pl /etc/usermin/miniserv.conf
satimis   5848  0.0  0.0   5024   828 pts/0    S+   00:56   0:00 grep usermin

Quote:
Second, do you have an entry in your /etc/hosts file for 'localhost 127.0.0.1' ? If not add it, and retry.
$ cat /etc/hosts | grep localhost
Code:
127.0.0.1       localhost.localdomain   localhost
::1     ip6-localhost ip6-loopback

satimis
 
Old 12-04-2007, 12:51 PM   #4
camorri
LQ Veteran
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2, current, slackware-arm-currnet
Posts: 5,478

Rep: Reputation: 632Reputation: 632Reputation: 632Reputation: 632Reputation: 632Reputation: 632
Those two items look good to me. I did some poking around, and in on the Webmin config you can set up IP access controls. If 127.0.0.1 is not in the list of allowed IP addresses, you would be allowed to connect with other IP's. So you domain name would be another IP.

If you can connect, have a look to see if 127.0.0.1 is an allowed IP address. If that doesn't fix it, I'm at a loss.
 
Old 12-04-2007, 08:49 PM   #5
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,679

Original Poster
Rep: Reputation: 55
Quote:
Originally Posted by camorri View Post
Those two items look good to me. I did some poking around, and in on the Webmin config you can set up IP access controls. If 127.0.0.1 is not in the list of allowed IP addresses, you would be allowed to connect with other IP's. So you domain name would be another IP.

If you can connect, have a look to see if 127.0.0.1 is an allowed IP address. If that doesn't fix it, I'm at a loss.
Hi camorri,


Thanks for your advice. The problem comes on iptables!!!


After running;

$ sudo iptables -F


both;
https://localhost:10000
https://localhost:20000

are working now.


Any advise howto disable modules on Usermin only allowing users changing password, languages, etc.


TIA


B.R.
satimis
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
usermin and webmin tutorial for Ubuntu Feisty satimis Linux - Server 0 11-23-2007 02:39 AM
Webmin/Usermin editor not UTF-8, options? sf2k Linux - Server 0 09-05-2007 04:16 PM
Bash Scripting and Webmin/Usermin cramer Programming 6 02-27-2006 05:50 PM
is webmin for server and usermin for client setup emailssent Linux - Networking 2 09-14-2004 10:07 PM
Starting webmin from Command Line BrettPower Linux - Networking 5 06-27-2004 01:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 10:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration