-   Linux - Server (
-   -   Problem installing "GNOME Desktop Environment". Please help.. :( (

roshanekka 06-16-2010 12:23 AM

Problem installing "GNOME Desktop Environment". Please help.. :(
hi friends,

I am trying to install "GNOME Desktop Environment" on my server. i used the following command:

yum groupinstall "GNOME Desktop Environment"

I got it from this tutorial:

Now when i started the installation on my centOS 5 server. i got the following error please see this image:

Now i wanted to know how can i fix that issue.

Please help me.

kbp 06-16-2010 01:36 AM

Try running 'yum install httpd' first and see if that helps


roshanekka 06-16-2010 08:21 AM

yum install httpd

didnt help me... and other idea. please help me guyz...

roshanekka 06-16-2010 10:00 AM

I think i have to find a repo where all the dependencies for installing Gnome desktop is present.

I enabled the plus and extras on my centos repo file. now i have started to get another errors, please check this image:

roshanekka 06-16-2010 11:40 AM

Hello any body there to reply me???? im replying myself.

roshanekka 06-16-2010 01:54 PM

ok i was tired with that error and i installed the gnome desktop environment by --skip-broken. It was installed successfully. i configured the VNC on my server. but now another problem :(

i am unable to connect using the VNC viewer.

I am getting following error:

please help me! :(

Im fixing my own problems. :( please help me!

John VV 06-16-2010 04:11 PM

well your mirror is timing out , it is a bad mirror

post 1
the error
it can not find apache server ( httpd)

post 4
it is not connecting

post 6
no network connection

what are you doing ??
as far as i can tell all 3 are different problems ?

most of the time a headless server dose not need Gnome installed ( headless no lcd screen )

what repos do you have installed and turned on ?
can you post the output of

yum repolist all

kbp 06-16-2010 05:41 PM

Hi roshanekka,

You need to realise that this is a free service where the people who may be able to help you have day jobs, lives outside of work and live all over the world in different time zones to you. Expecting a 2 hour response is a little unrealistic for this service, if you need that kind of response there are many companies that are very happy to charge you lots. It's also not the best form to have several different problems in the same thread, try starting a new thread with a relevant title,

hope this helps

roshanekka 06-16-2010 11:34 PM

@ John VV:

First of all thanks for reading this complete thread and taking time to reply me. Thanks sir.

Problem #1: you say that the httpd is not found but i see that httpd is responding fine on my server. but i didnt understand why im getting that error.

Problem #2: i did some changes on my repo because of that i started to get that problem but later i managed to get a good working mirror. (This problem is solved)

Problem #3: Now when i tried to use VNC viewer from my Home PC i started to get the No Network connection error. I added the port on iptables and checked if firewalls are blocking it. but firewalls isnt blocking my connection. i did double check on my HOme PC firewall and even on my server.

I want to access my server from home. like a remote desktop. i hope you understood what i am doing.

Now here is the output of "yum repolist all":

root@server2 [~]# yum repolist all
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* addons:
* base:
* centosplus:
* extras:
* updates:
addons | 951 B 00:00
base | 2.1 kB 00:00
centosplus | 1.9 kB 00:00
extras | 2.1 kB 00:00
updates | 1.9 kB 00:00
repo id repo name status
addons CentOS-5 - Addons enabled: 0
base CentOS-5 - Base enabled: 2,599
c5-media CentOS-5 - Media disabled
centosplus CentOS-5 - Plus enabled: 207
contrib CentOS-5 - Contrib disabled
extras CentOS-5 - Extras enabled: 327
updates CentOS-5 - Updates enabled: 228
repolist: 3,361


@kbp: Yeah i do understand that its a free work and people out there are much busy. Im sorry if i did something wrong. im a newbie and i thought there are people who will reply me in minutes as this is one of the most popular forum.

i posted the different problems in same thread because it was all related to the same stuff. i thought if i keep all these problems here which is related to a single stuff then people who are going to help me will not have to enter different and different threads and it will be lot easier to understand my problem. Im sorry if i violated any terms or rules here. :(

roshanekka 06-18-2010 01:30 AM

No body replied! :(

roshanekka 06-21-2010 11:52 AM

Well no body replied here. I felt very bad. But some how i installed everything myself.

SO i am going to share what was my experience and problems and fix to all those problems.

First of all i would like to mention that i tried to install a GUI on my headless remote server. I wanted to use it from my PC at home (WIndows XP PC).

now you will have to follow this link for installation: (I did all this on CentOS)

Now here are the problems that you are going to face while installing Gnome (I selected gnome, but you can select your own desired desktop other than gnome).

Problem #1: When we run "yum groupinstall "GNOME Desktop Environment"", we get an error which says httpd dependencies missing.

Solution: Look which version of "gnome-user-share" was having dependency problem, now google and find out the rpm for this "gnome-user-share". When you get the rpm wget it to the server. and install it with --nodeps it will install without any problem. Now run "yum groupinstall "GNOME Desktop Environment"" it will be installed successfully.

Problem #2: Unable to connect.

Solution: This is due to the firewall. Double check the Firewall. Check your firewall system and the firewall that you have installed on your server. add the port so that the connections get established easily.

My problem is solved but if you face problem try and try and try to google. and you will be able to fix your issue yourself. like i did.

All times are GMT -5. The time now is 01:07 PM.