-   Linux - Server (
-   -   Problem booting on new kernel after update (

pmorin 07-20-2011 05:36 AM

Problem booting on new kernel after update
Hello, I've got a problem with my Ubuntu Server 11.04 amd64, I think the problem comes from GRUB 2.

Here is my problem : I updated my server and I now have Linux 2.6.38-10-server (in addition to 2.6.38-8) and, when I try to boot on version "10", I think I have a Kernel Panic because the screen keeps black and there is no use of the HDD (I can ear it working with version "8").

I also looked at /boot/grub/grub.cfg and I didn't saw any diference between the lines for v10 and those for v8 (except for "8">"10" of course).

I tried with Recovery Mode too, with this result :
Loading Linux 2.6.38-10-server...
Loading initial ramdisk...
> No use of the HDD (I don't ear it), and it's "frozen", can't do anyting but reboot it by ACPI (nothing happend when hitting "Num Lock")

Another question : can we have no submenus in Grub2 ?

Thank you for your help !


ITPhoenix 07-20-2011 11:51 AM

I am not an expert but practical experience has led me to perform a full system image backup on a regular basis. That said, I see too many problems with kernel updates in the forums. Instead of spending endless hours trying to get the updated system to work, consider a clean install with the new kernel. If you do not have an image backup, you could copy all your files to disk then do the clean install. I have found that clean installs are not guaranteed to work either, but when I wipe the disk, e.g.., "clean all" in diskpart, the clean install works everytime. Also, checking the image with the MD5 before you burn, and verifying the disk during the burning process, is highly recommended.

andrewthomas 07-20-2011 11:55 AM

Try to regenerate the initramfs image:


sudo update-initramfs -u -k all

pmorin 07-20-2011 12:46 PM

@ ITPheonix : Thank you for your help. A clean install for each kernel update is not possible for me : too much work for that at each update.

@ andrewthomas : I tried but it doesn't have changed anything.

Note that the kernel seems to be OK becaus I managed to boot on it by booting on Recovery Mode and playing with the power button of the computer. Yes, I said that I had to push the Power button (computer turned on) many times to make it work (I've done that only once). That's REALLY weird.

Moreover, I saw a strange message at Recovery boot : it said me that /dev/disk/by-uuid/d84ca57a-7661-4ff1-b8a6-7f983c37da20 (the boot HDD) isn't found, but all is in, and the v8 kernel is working (and I verified : it really exists).

Do you see anything else ?

yancek 07-20-2011 03:52 PM

The uuid refers to partitions. Run either or both of these commands to check the output against your error message:

sudo blkid

ls /dev/disk/by-uuid

What does "all is in" mean in your last sentence?
Do you have a separate /boot partition?

pmorin 07-21-2011 04:02 AM

Here is the result of "ls -lA /dev/disk/by-uuid/"

lrwxrwxrwx 1 root root 10 2011-07-20 18:35 1E3A68653A683BC1 -> ../../sda2
lrwxrwxrwx 1 root root 10 2011-07-20 18:35 2C32E5F932E5C7C2 -> ../../sda4
lrwxrwxrwx 1 root root 10 2011-07-20 18:35 4638671F38670D6D -> ../../sda1
lrwxrwxrwx 1 root root 10 2011-07-20 18:35 d0be62be-9235-448e-aa86-2a2aed10f535 -> ../../sda6
lrwxrwxrwx 1 root root 10 2011-07-20 18:35 d84ca57a-7661-4ff1-b8a6-7f983c37da20 -> ../../sda5
Here is the result of "sudo blkid"

/dev/sda1: LABEL="SYSTEM" UUID="4638671F38670D6D" TYPE="ntfs"
/dev/sda2: LABEL="COMPAQ" UUID="1E3A68653A683BC1" TYPE="ntfs"
/dev/sda4: LABEL="FACTORY_IMAGE" UUID="2C32E5F932E5C7C2" TYPE="ntfs"
/dev/sda5: UUID="d84ca57a-7661-4ff1-b8a6-7f983c37da20" TYPE="ext4"
/dev/sda6: UUID="d0be62be-9235-448e-aa86-2a2aed10f535" TYPE="swap"
Here is the result of "sudo fdisk -l"

Disque /dev/sda: 750.2 Go, 750156374016 octets
255 têtes, 63 secteurs/piste, 91201 cylindres
Unités = cylindres de 16065 * 512 = 8225280 octets
Taille de secteur (logique / physique)*: 512*octets / 512*octets
taille d'E/S (minimale / optimale)*: 512*octets / 512*octets
Identifiant de disque : 0xb42aa3a6

Périphérique Amorce Début Fin Blocs Id Système
/dev/sda1 * 1 13 102400 7 HPFS/NTFS
La partition 1 ne se termine pas sur une frontière de cylindre.
/dev/sda2 13 28973 232617187+ 7 HPFS/NTFS
/dev/sda3 28973 89759 488266753 5 Etendue
/dev/sda4 89759 91202 11584512 7 HPFS/NTFS
/dev/sda5 28973 89270 484335616 83 Linux
/dev/sda6 89270 89759 3930112 82 Linux swap / Solaris
All of "Linux" is in the "/dev/sda5" partition (the data, the system, the boot...).

I ran those commands on the v8 kernel.

andrewthomas 07-21-2011 08:40 AM


Originally Posted by pmorin (Post 4420305)
Moreover, I saw a strange message at Recovery boot : it said me that /dev/disk/by-uuid/d84ca57a-7661-4ff1-b8a6-7f983c37da28


Originally Posted by pmorin (Post 4420305)
/dev/sda5: UUID="d84ca57a-7661-4ff1-b8a6-7f983c37da20" TYPE="ext4"

Is the boot message a typo?

pmorin 07-21-2011 11:22 AM

Sorry, I made a mistake in my first post.
I edit.

d84ca57a-7661-4ff1-b8a6-7f983c37da20 is the correct value.

yancek 07-21-2011 01:54 PM

Could you post the relevant parts of the grub.cfg file? Someone might see something you overlooked. Can't see anything else with the information you have posted?

pmorin 07-22-2011 03:58 AM

1 Attachment(s)
Here is my grub.cnf file (I don't know what part is absolutely revelent).


All times are GMT -5. The time now is 09:53 AM.