LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 07-15-2012, 11:17 AM   #1
nap_blownapart
LQ Newbie
 
Registered: Jul 2012
Posts: 8

Rep: Reputation: Disabled
Prevent Postfix sending mail to local mailboxes in a virtual-host setup


Hi,

I'm running Ubuntu 10.04 LTS with Postfix/Dovecot and ISPConfig3.

I have 3 domains co-hosted on my VPS each with their respective email accounts.
I've noticed that it is possible for me to send an email using an account from one of these domains to an account on one of the other domains without having to supply the right password. This is a potential problem as it is highly likely that the owners of these 2 domains are not the same. It is also true that the two owners probably aren't aware they share the same server, but I'm not banking on that for my security.

While I've been able to prevent mail destined for other servers going out without proper authentication, I can't seem to stop local mail from being delivered locally.
I want local mail to ONLY be delivered when the user has supplied their password correctly.

For some reason, almost everything on this subject I'm finding through google etc is attempting to do other things with local mail, usually with local mail not working.

Is there a way of doing this through configuration of Postfix or Dovecot? Or, do I need another package to handle this?

Best regards,
Nap

Last edited by nap_blownapart; 07-15-2012 at 11:21 AM.
 
Old 07-16-2012, 10:31 AM   #2
grim76
Member
 
Registered: Jun 2007
Distribution: Debian, SLES, Ubuntu
Posts: 308

Rep: Reputation: 50
Look into using /etc/aliases that might be more of what you are looking for.
 
Old 07-24-2012, 05:39 AM   #3
nap_blownapart
LQ Newbie
 
Registered: Jul 2012
Posts: 8

Original Poster
Rep: Reputation: Disabled
thn Grim, I will do that.
 
Old 07-24-2012, 06:00 AM   #4
vishesh
Member
 
Registered: Feb 2008
Distribution: Fedora,RHEL,Ubuntu
Posts: 661

Rep: Reputation: 66
Please check whats the value of smtpd_recipient_restiction value . If mynetwork include local network then this could be the issue

Whats output on

postconf -n|grep mynetw

If mynetwork mentioned in following

smtpd_client_restrictions
smtpd_recipient_restrictions
smtpd_sender_restrictions

And mynetwork include local network then its advisable to remove mynetwork from these variables

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix not sending mail - Host MX records not found? kayasaman Linux - Server 8 01-20-2012 11:47 AM
prevent user from sending mail in postfix onyangoliech Linux - Networking 2 12-15-2006 07:37 AM
prevent user from sending mail in postfix onyangoliech Linux - Networking 1 12-14-2006 07:29 AM
mail filtering with Postfix and virtual mailboxes pembo13 Linux - Networking 2 09-17-2004 07:09 AM
postfix : sending local mail without domain iainr Linux - Software 2 12-10-2003 03:05 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 07:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration