LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (https://www.linuxquestions.org/questions/linux-server-73/)
-   -   postfix sasl . no mechanism available (https://www.linuxquestions.org/questions/linux-server-73/postfix-sasl-no-mechanism-available-944493/)

swanny99 05-11-2012 07:40 PM

postfix sasl . no mechanism available
 
Trying to alter postfix so that I can relay email to smtp.com

Error in /var/log/mailllog :-
... SASL authentication failed; cannot authenticate to server ... no mechanism available

/etc/postfix/sasl_passwd
have done:-
postmap sasl_passwd

in main.cf tried both:-
smtp_sasl_security_options = noanonymous and:-
smtp_sasl_security_options =

Postfix was installed as part of the server package. I didn't install it or any of its parts.

Setup guide from smtp.com asked to add password/username to sasl_passwd, but there was no sasl_passwd file on the server. I created it in /etc/postfix

Nothing seems to make any difference. Still the same error. Any suggestions welcome.

swanny99 05-12-2012 11:01 AM

new error
 
after hours of trial with the same error, I am delighted to see a new error in /var/log/maillog:-

"unknown mail transport error"

The only thing I changed was [] round the relayhost:-
relayhost=[path.smtp.com:2525]
exactly the same in the sasl_passwd file.

Not sure if this is progress or not.

Any suggestions welcome.

Edit:-
After further reading, think relayhost should be [path.smtp.com]:2525 and password file does not require port.

Anyway, nothing works. Still same errors.

kyrunner 05-12-2012 06:48 PM

Here you go this is for Centos

yum install cyrus-sasl-plain

votsalo 03-10-2015 08:57 AM

Ubuntu
 
For ubuntu (12.04 and probably 14.04) x64:

apt-get install libsasl2-modules


All times are GMT -5. The time now is 12:25 PM.