-   Linux - Server (
-   -   portmap package problem (

vidyasagar6 02-02-2013 02:05 AM

portmap package problem
I downloaded portmap package and installed by using command #rpm -i portmap

after that i restart the services i got error message:
Stopping portmap services:[FAILED]
Starting portmapper: portmap: relocation error: portmap: symbol errno, version GLIBC_2.0
not defined in file with link time reference[FAILED]

Later i tried to remove package

[root@rhel6 Desktop]# rpm -e portmap-4.0-17.i386.rpm
error: package portmap-4.0-17.i386.rpm is not installed

again i tried to install same package

[root@rhel6 Desktop]# rpm -i portmap-4.0-17.i386.rpm
package portmap-4.0-17.i386 is already installed

I am not able to remove or install properly .but now i want that package to set up nfs file server

Please help me resolve this problem

John VV 02-02-2013 11:56 PM

why are you using rpm ?

"yum" ( or "zypper" if suse) is there to install needed prerequisites

What operating system is this ?
And it's version
CentOS 6.3 ?
RHEL 6.3 ?
Fedora 18 ?( should NOT be installed on a server )
SELS 11 ( SUSE )?


su -
yum search portmap
--- if SELS ( suse) then ---
zypper se portmap

vidyasagar6 02-03-2013 08:17 AM

Hi, John


6.3 Release

host does't have internet Connection

John VV 02-03-2013 01:09 PM

for starters "portmap-4.0-17.i386" is for the very ancient RH6 ( from the year 1999)
and not the current RHEL 6.3

Red Hat chanced it's naming back in `03
the very OLD RH6 is not the same as the current RHEL 6

it will never install on a modern OS

try this

su -
rpm -e portmap-4.0-17
----------- or ----------
yum remove  portmap-4.0-17

what exactly are you trying to do ?

there is a RHEL 5 version but red hat changed a lot of things in RHEL6

rpcbind or NFS might likely be what you need to configure

All times are GMT -5. The time now is 01:05 AM.