LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 05-24-2017, 12:31 PM   #1
nibraz
Member
 
Registered: Oct 2008
Posts: 219

Rep: Reputation: 18
php upgrade failing


Hi

I got centos 6.9 and i followed a guide to upgrade php version 5.6 to php 7.1 but i am getting the below error:
]
Code:
[root@www #]# wget https://dl.fedoraproject.org/pub/epel/epel-release-latest                                     -6.noarch.rpm
--2017-05-24 17:22:51--  https://dl.fedoraproject.org/pub/epel/epel-release-late                                     st-6.noarch.rpm
Resolving dl.fedoraproject.org... 209.132.181.24, 209.132.181.23, 209.132.181.25
Connecting to dl.fedoraproject.org|209.132.181.24|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 14540 (14K) [application/x-rpm]
Saving to: “epel-release-latest-6.noarch.rpm.1”

100%[======================================>] 14,540      --.-K/s   in 0.1s

2017-05-24 17:22:52 (96.6 KB/s) - “epel-release-latest-6.noarch.rpm.1” saved [14                                     540/14540]

[root@www #]# wget http://rpms.remirepo.net/enterprise/remi-release-6.rpm
--2017-05-24 17:23:00--  http://rpms.remirepo.net/enterprise/remi-release-6.rpm
Resolving rpms.remirepo.net... 2001:bc8:33a1:100::1, 195.154.241.117
Connecting to rpms.remirepo.net|2001:bc8:33a1:100::1|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 8344 (8.1K) [application/x-rpm]
Saving to: “remi-release-6.rpm.1”

100%[======================================>] 8,344       --.-K/s   in 0.001s

2017-05-24 17:23:00 (6.14 MB/s) - “remi-release-6.rpm.1” saved [8344/8344]

[root@www #]# rpm -Uvh remi-release-6.rpm epel-release-latest-6.noarch.rpm
warning: remi-release-6.rpm: Header V4 DSA/SHA1 Signature, key ID 00f97f56: NOKE                                     Y
Preparing...                ########################################### [100%]
   1:epel-release           ########################################### [ 50%]
   2:remi-release           ########################################### [100%]
[root@www #]# yum install yum-utils
Loaded plugins: fastestmirror, priorities, refresh-packagekit, security
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: mirror.mhd.uk.as44574.net
 * epel: fr.mirror.babylon.network
 * extras: mirror.mhd.uk.as44574.net
 * remi-safe: fr.mirror.babylon.network
 * rpmforge: ftp.nluug.nl
 * updates: mirror.mhd.uk.as44574.net
Package yum-utils-1.1.30-40.el6.noarch already installed and latest version
Nothing to do
[root@www #]# yum-config-manager --enable remi-php71
Loaded plugins: fastestmirror, priorities, refresh-packagekit
=============================== repo: remi-php71 ===============================
[remi-php71]
bandwidth = 0
base_persistdir = /var/lib/yum/repos/x86_64/6
baseurl =
cache = 0
cachedir = /var/cache/yum/x86_64/6/remi-php71
cost = 1000
enabled = 1
enablegroups = True
exclude =
failovermethod = priority
ftp_disable_epsv = False
gpgcadir = /var/lib/yum/repos/x86_64/6/remi-php71/gpgcadir
gpgcakey =
gpgcheck = True
gpgdir = /var/lib/yum/repos/x86_64/6/remi-php71/gpgdir
gpgkey = file:///etc/pki/rpm-gpg/RPM-GPG-KEY-remi
hdrdir = /var/cache/yum/x86_64/6/remi-php71/headers
http_caching = all
includepkgs =
keepalive = True
mdpolicy = group:primary
mediaid =
metadata_expire = 21600
metalink =
mirrorlist = http://rpms.remirepo.net/enterprise/6/php71/mirror
mirrorlist_expire = 86400
name = Remi's PHP 7.1 RPM repository for Enterprise Linux 6 - x86_64
old_base_cache_dir =
password =
persistdir = /var/lib/yum/repos/x86_64/6/remi-php71
pkgdir = /var/cache/yum/x86_64/6/remi-php71/packages
priority = 99
proxy = False
proxy_dict =
proxy_password =
proxy_username =
repo_gpgcheck = False
retries = 10
skip_if_unavailable = False
ssl_check_cert_permissions = True
sslcacert =
sslclientcert =
sslclientkey =
sslverify = True
throttle = 0
timeout = 30.0
username =

[root@www #]# yum update
Loaded plugins: fastestmirror, priorities, refresh-packagekit, security
Setting up Update Process
Loading mirror speeds from cached hostfile
 * base: ftp.hosteurope.de
 * epel: epel.vpsnet.lt
 * extras: ftp.hosteurope.de
 * remi-php71: remi.mirror.wearetriple.com
 * remi-safe: remi.mirror.wearetriple.com
 * rpmforge: ftp.nluug.nl
 * updates: ftp.hosteurope.de
remi-php71                                               | 2.9 kB     00:00
Not using downloaded repomd.xml because it is older than what we have:
  Current   : Wed May 24 14:39:01 2017
  Downloaded: Wed May 24 09:48:56 2017
Resolving Dependencies
--> Running transaction check
---> Package awstats.noarch 0:7.0-3.el6 will be updated
---> Package awstats.noarch 0:7.1-1.el6.rf will be an update
--> Processing Dependency: perl(Geo::IP) for package: awstats-7.1-1.el6.rf.noarc                                     h

Error: Package: gd-last-2.2.4-1.el7.remi.x86_64 (remi-safe)
           Requires: libpng15.so.15(PNG15_0)(64bit)
Error: Package: remi-release-7.3-1.el7.remi.noarch (remi-safe)
           Requires: epel-release = 7
           Installed: epel-release-6-8.noarch (@epel)
               epel-release = 6-8
Error: Package: php-imap-7.1.5-1.el7.remi.x86_64 (remi-php71)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-common-7.1.5-1.el7.remi.x86_64 (remi-php71)
           Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: gd-last-2.2.4-1.el7.remi.x86_64 (remi-safe)
           Requires: libtiff.so.5(LIBTIFF_4.0)(64bit)
Error: Package: gd-last-2.2.4-1.el7.remi.x86_64 (remi-safe)
           Requires: libwebp.so.4()(64bit)
Error: Package: php-7.1.5-1.el7.remi.x86_64 (remi-php71)
           Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: php-7.1.5-1.el7.remi.x86_64 (remi-php71)
           Requires: httpd-mmn = 20120211x8664
           Installed: httpd-2.2.15-59.el6.centos.x86_64 (@base)
               httpd-mmn = 20051115
Error: Package: gd-last-2.2.4-1.el7.remi.x86_64 (remi-safe)
           Requires: libtiff.so.5()(64bit)
Error: Package: php-gd-7.1.5-1.el7.remi.x86_64 (remi-php71)
           Requires: libpng15.so.15()(64bit)
Error: Package: gd-last-2.2.4-1.el7.remi.x86_64 (remi-safe)
           Requires: libpng15.so.15()(64bit)
Error: Package: php-odbc-7.1.5-1.el7.remi.x86_64 (remi-php71)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-ldap-7.1.5-1.el7.remi.x86_64 (remi-php71)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-mcrypt-7.1.5-1.el7.remi.x86_64 (remi-php71)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-snmp-7.1.5-1.el7.remi.x86_64 (remi-php71)
           Requires: libnetsnmp.so.31()(64bit)
Error: Package: php-process-7.1.5-1.el7.remi.x86_64 (remi-php71)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-ldap-7.1.5-1.el7.remi.x86_64 (remi-php71)
           Requires: libsasl2.so.3()(64bit)
Error: Package: php-xcache-3.0.4-1.el6.x86_64 (@epel)
           Requires: php(api) = 20090626
           Removing: php-common-5.3.3-49.el6.x86_64 (@base)
               php(api) = 20090626
           Updated By: php-common-7.1.5-1.el7.remi.x86_64 (remi-php71)
               php(api) = 20160303-64
           Available: php-common-7.1.4-1.el7.remi.x86_64 (remi-php71)
               php(api) = 20160303-64
Error: Package: php-soap-7.1.5-1.el7.remi.x86_64 (remi-php71)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-xcache-3.0.4-1.el6.x86_64 (@epel)
           Requires: php(zend-abi) = 20090626
           Removing: php-common-5.3.3-49.el6.x86_64 (@base)
               php(zend-abi) = 20090626
           Updated By: php-common-7.1.5-1.el7.remi.x86_64 (remi-php71)
               php(zend-abi) = 20160303-64
           Available: php-common-7.1.4-1.el7.remi.x86_64 (remi-php71)
               php(zend-abi) = 20160303-64
Error: Package: php-xml-7.1.5-1.el7.remi.x86_64 (remi-php71)
           Requires: libxml2.so.2(LIBXML2_2.9.0)(64bit)
Error: Package: php-pdo-dblib-7.1.5-1.el7.remi.x86_64 (remi-php71)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-xml-7.1.5-1.el7.remi.x86_64 (remi-php71)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-json-7.1.5-1.el7.remi.x86_64 (remi-php71)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-cli-7.1.5-1.el7.remi.x86_64 (remi-php71)
           Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: php-snmp-7.1.5-1.el7.remi.x86_64 (remi-php71)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-pecl-mysql-1.0.0-0.15.20160812git230a828.el7.remi.7.1.x86_64                                      (remi-php71)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-xmlrpc-7.1.5-1.el7.remi.x86_64 (remi-php71)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-pdo-7.1.5-1.el7.remi.x86_64 (remi-php71)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: gd-last-2.2.4-1.el7.remi.x86_64 (remi-safe)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-mysqlnd-7.1.5-1.el7.remi.x86_64 (remi-php71)
           Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: php-mbstring-7.1.5-1.el7.remi.x86_64 (remi-php71)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-tidy-7.1.5-1.el7.remi.x86_64 (remi-php71)
           Requires: libc.so.6(GLIBC_2.14)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Does anyone know why?
 
Old 05-24-2017, 06:58 PM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,400

Rep: Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584Reputation: 2584
the major version of php and the lamp stack will never change in the lifetime of cent6 ( from 6.0 to 6.9 - after 7 years)

cent 6 is showing its AGE -- it is " over the hill"

now as to the mess of incompatible repos " remi" really and the dead "rpmforge"

and mixing those two with epel

-- that is a recipe FOR DISASTER

and the kicker is that remi repo IS FOR CENT 7 not 6

Quote:
emi-release-7.3-1.el7.remi.noarch (remi-safe)

this might be a FUBAR install and unfixable ( or not ??? )

remove the el7 remi repo AND ALL!!!!!!! rpm's that you installed from it

then remove ALL rpmforge ( .rf) rpm's

Code:
rpm -qa | grep rf
will give you a list that needs to be uninstalled

and install "yum-priorites" plugin AND CONFIGURE IT!!!@!@!!!!!

please see the centos wiki
https://wiki.centos.org/AdditionalRe...s/Repositories
the plugin
https://wiki.centos.org/PackageManag...Yum/Priorities

Last edited by John VV; 05-24-2017 at 07:02 PM.
 
Old 05-25-2017, 04:10 AM   #3
nibraz
Member
 
Registered: Oct 2008
Posts: 219

Original Poster
Rep: Reputation: 18
Quote:
Originally Posted by John VV View Post
the major version of php and the lamp stack will never change in the lifetime of cent6 ( from 6.0 to 6.9 - after 7 years)

cent 6 is showing its AGE -- it is " over the hill"

now as to the mess of incompatible repos " remi" really and the dead "rpmforge"

and mixing those two with epel

-- that is a recipe FOR DISASTER

and the kicker is that remi repo IS FOR CENT 7 not 6




this might be a FUBAR install and unfixable ( or not ??? )

remove the el7 remi repo AND ALL!!!!!!! rpm's that you installed from it

then remove ALL rpmforge ( .rf) rpm's

Code:
rpm -qa | grep rf
will give you a list that needs to be uninstalled

and install "yum-priorites" plugin AND CONFIGURE IT!!!@!@!!!!!

please see the centos wiki
https://wiki.centos.org/AdditionalRe...s/Repositories
the plugin
https://wiki.centos.org/PackageManag...Yum/Priorities
This is what I got from the output:

Code:
rpm -qa | grep rf
librtmp-devel-2.3-1.el6.rf.x86_64
ffmpeg-libpostproc-0.6.5-1.el6.rf.x86_64
faac-devel-1.26-1.el6.rf.x86_64
ffmpeg-0.6.5-1.el6.rf.x86_64
lame-3.99.5-1.el6.rf.x86_64
rfkill-0.3-4.el6.x86_64
ffmpeg-devel-0.6.5-1.el6.rf.x86_64
rpmforge-release-0.5.3-1.el6.rf.x86_64
perl-XML-SAX-Base-1.04-1.el6.rf.noarch
a52dec-devel-0.7.4-8.el6.rf.x86_64
librtmp-2.3-1.el6.rf.x86_64
a52dec-0.7.4-8.el6.rf.x86_64
faad2-2.7-1.el6.rf.x86_64
php-pear-db-1.7.13-2.el6.rf.noarch
x264-0.0.0-0.4.20101111.el6.rf.x86_64
faac-1.26-1.el6.rf.x86_64
opencore-amr-0.1.2-1.el6.rf.x86_64
x264-devel-0.0.0-0.4.20101111.el6.rf.x86_64
lame-devel-3.99.5-1.el6.rf.x86_64
faad2-devel-2.7-1.el6.rf.x86_64
phpmyadmin-2.11.11.3-2.el6.rf.noarch
unrar-5.0.3-1.el6.rf.x86_64
opencore-amr-devel-0.1.2-1.el6.rf.x86_64
This is live webserver with my website running with active users..

It shows as "el6" do I uninstall all the above from the output?

Thanks
 
Old 05-25-2017, 04:22 AM   #4
nibraz
Member
 
Registered: Oct 2008
Posts: 219

Original Poster
Rep: Reputation: 18
also how do i upgrade php to version 7?

current version:

Quote:
PHP 5.3.3 (cli) (built: Mar 22 2017 12:27:09)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
with XCache v3.0.4, Copyright (c) 2005-2013, by mOo
with XCache Optimizer v3.0.4, Copyright (c) 2005-2013, by mOo
with XCache Cacher v3.0.4, Copyright (c) 2005-2013, by mOo
with XCache Coverager v3.0.4, Copyright (c) 2005-2013, by mOo
 
Old 05-25-2017, 03:34 PM   #5
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 9,917
Blog Entries: 7

Rep: Reputation: 2442Reputation: 2442Reputation: 2442Reputation: 2442Reputation: 2442Reputation: 2442Reputation: 2442Reputation: 2442Reputation: 2442Reputation: 2442Reputation: 2442
Quote:
Originally Posted by nibraz View Post
also how do i upgrade php to version 7?
Quote:
Originally Posted by John VV View Post
the major version of php and the lamp stack will never change in the lifetime of cent6 ( from 6.0 to 6.9 - after 7 years)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] pacman system upgrade failing Brosef_Stalin Linux - Software 2 02-06-2016 06:26 PM
PHP mail() Function Failing devUnix Programming 4 12-05-2011 02:34 AM
PHP with OpenSSL Support Failing pinstripe Linux - Server 4 12-20-2009 09:17 AM
xorg upgrade to 1.6 failing dannyk1 Gentoo 4 11-27-2009 11:07 AM
PHP File Uploads Failing gmcmaster Linux - Software 3 04-28-2006 05:39 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 07:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration