LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 02-20-2008, 08:55 PM   #1
pbeane
LQ Newbie
 
Registered: Feb 2008
Posts: 6

Rep: Reputation: 0
PHP Not Working - CentOS 4.6 w/ Virtualmin


OK, so PHP was extremely outdated (the one that Virtualmin compiled/installed was 4.3.9), so I tried to update it using the following configure statement:

Quote:
./configure --enable-bcmath --enable-calendar --enable-dbase --enable-exif --enable-force-cgi-redirect --enable-ftp --enable-libxml --enable-magic-quotes --enable-mbstring --enable-pdo=shared --enable-sockets --enable-zip --prefix=/usr/local --with-bz2 --with-config-file-path=/usr/local/lib --with-config-file-scan-dir=/usr/local/lib/php.ini.d --with-curl=/opt/curlssl/ --with-curlwrappers --with-gd --with-gettext --with-jpeg-dir=/usr --with-kerberos=/usr --with-libexpat-dir=/usr --with-libxml-dir=/opt/xml2/ --with-mcrypt=/opt/libmcrypt/ --with-mhash=/opt/mhash/ --with-mysql=/usr --with-mysql-sock=/var/lib/mysql/mysql.sock --with-mysqli=/usr/bin/mysql_config --with-pdo-mysql=shared --with-pdo-sqlite=shared --with-png-dir=/usr --with-pspell --with-sqlite=shared --with-tidy=/opt/tidy/ --with-xmlrpc --with-xsl=/opt/xslt/ --with-zlib --with-zlib-dir=/usr --with-freetype-dir=/usr --with-apxs2=/usr/sbin/apxs
All went well... I edited httpd.conf to load the PHP 5 module, and compiled PHP, and restarted Apache. Now, any PHP sites I try to access on my server load a blank page. Any ideas? I need to get this fixed ASAP...

Thanks.
 
Old 02-20-2008, 09:59 PM   #2
pbeane
LQ Newbie
 
Registered: Feb 2008
Posts: 6

Original Poster
Rep: Reputation: 0
Fixed, all is good.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mailmen Problems in Virtualmin with CentOS 4.6 pbeane Linux - Server 2 04-01-2008 03:07 PM
Fedora 7 & CentOS 5 PHP not working flegace Linux - Server 5 08-30-2007 01:12 AM
Installing php on CentOS 4.2 Digital Surgeon Programming 2 01-05-2006 11:19 AM
Virtualmin Configuration Equin Linux - Software 1 08-18-2005 06:01 PM
some help with CentOS PHP issue please! renegadeavenger Red Hat 5 08-08-2005 08:33 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 12:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration