-   Linux - Server (
-   -   php.ini.rpmsave instead of php.ini (

ilvista 02-01-2011 07:50 AM

php.ini.rpmsave instead of php.ini
hi guys

i had a problem with my httpd php installation ,so i remove them and also removed php.ini from /etc/ and then made a new installation.
Fortunately now it works except i'm having this error each time time i use time

Warning: date() []: It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EST/-5.0/no DST' instead in /var/www/a2billing/common/lib/admin.defines.php on line 165
so i tried to added date.timezone to my php.ini but i can't find it although php is working fine ,But instead of it find php.ini.rpmsave,and when i added date.timezone ,the problem exist!!!
another strange thing locate CMD tells me that php.ini file is in /etc.

[root@benchabane ~]# locate php.ini


[root@benchabane ~]# vi /etc/php.ini
"/etc/php.ini" [New File]

the phpinfo tells me

Configuration File (php.ini) Path        /etc
Loaded Configuration File                (none)

is there any explanation????
I'm running fedora 14 server,apache 2.2.17 php 5.3.5

php -v says:

[root@benchabane etc]# php -v
PHP 5.2.17 (cli) (built: Jan 31 2011 20:21:21)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2010 Zend Technologies

am'i running two copies of php??
thx in advance

Snark1994 02-01-2011 10:34 AM


ls -l /etc/php.ini

locate php.ini

Locate runs from a stored database of filelocations, it doesn't actually search your hard-drive. It's possible you've moved/deleted the php.ini file since it last updated :)

ilvista 02-01-2011 01:37 PM


[root@benchabane benchabane]# ls -l /etc/php.ini
ls: cannot access /etc/php.ini: No such file or directory

but updatedb cleared things up,now i know for sure that the php.ini is missing
thank you

Snark1994 02-01-2011 04:39 PM

Great :) if this solved your problem, then please mark the thread as "SOLVED" (under Thread Tools)

All times are GMT -5. The time now is 06:51 AM.