LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 04-30-2009, 06:30 AM   #1
cviniciusm
LQ Newbie
 
Registered: Apr 2005
Posts: 20

Rep: Reputation: 0
Question Permission denied between clamav-daemon and amavisd-new on Ubuntu 9.04 .


Hello,

I'm trying to use clamav-daemon with amavisd-new, but I'm getting the following errors.

Any ideas, please?

I'm using Ubuntu 9.04 and the following packages:
amavisd-new 1:2.6.2-2ubuntu2
clamav 0.95.1+dfsg-1ubuntu1
clamav-daemon 0.95.1+dfsg-1ubuntu1
postfix 2.5.5-1.1
dovecot-common 1:1.1.11-0ubuntu4
dovecot-imapd 1:1.1.11-0ubuntu4
dovecot-pop3d 1:1.1.11-0ubuntu4

Code:
/var/log/mail.err:
"
...
... amavis[19678]: (19678-02-2) (!!)run_av (ClamAV-clamd) FAILED - unexpected , output="/var/lib/amavis/tmp/amavis-2009
0430T054622-19678/parts: lstat() failed: Permission denied. ERROR\n"
... amavis[19678]: (19678-02-2) (!!)ClamAV-clamd av-scanner FAILED: CODE(0x92f8a00) unexpected , output="/var/lib/amavi
s/tmp/amavis-20090430T054622-19678/parts: lstat() failed: Permission denied. ERROR\n" at (eval 98) line 543.
...
"

/var/log/clamav/clamav.log:
"
...
WARNING: lstat() failed on: /var/lib/amavis/tmp/amavis-20090430T054622-19678/parts
...
"

/etc/postfix/master.cf:
"
...
smtp-amavis     unix    -       -       -       -       2       smtp
        -o smtp_data_done_timeout=1200
        -o smtp_send_xforward_command=yes
        -o disable_dns_lookups=yes
        -o max_use=20

127.0.0.1:10025 inet    n       -       -       -       -       smtpd
...
"

/etc/amavis/conf.d/15-av_scanners:
"
...
 ### http://www.clamav.net/
 ['ClamAV-clamd',
   \&ask_daemon, ["CONTSCAN {}\n", "/var/run/clamav/clamd.ctl"],
   qr/\bOK$/, qr/\bFOUND$/,
   qr/^.*?: (?!Infected Archive)(.*) FOUND$/m ],
 # NOTE: remember to add the clamav user to the amavis group, and
 # to properly set clamd to init supplementary groups
 # When running chrooted one may prefer: ["CONTSCAN {}\n","$MYHOME/clamd"],
...
"

# groups clamav
clamav amavis

TIA,
cviniciusm.
 
Old 04-30-2009, 06:44 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,609

Rep: Reputation: 1802Reputation: 1802Reputation: 1802Reputation: 1802Reputation: 1802Reputation: 1802Reputation: 1802Reputation: 1802Reputation: 1802Reputation: 1802Reputation: 1802
Quote:
# NOTE: remember to add the clamav user to the amavis group, and
# to properly set clamd to init supplementary groups
Have you done the above? You have added amavis to clamav group and not the other way around.
Also don't forget to uncomment the "AllowSupplementaryGroups" option in clamd.conf and restart both clamd and amavisd.

Regards
 
1 members found this post helpful.
Old 04-30-2009, 07:21 AM   #3
cviniciusm
LQ Newbie
 
Registered: Apr 2005
Posts: 20

Original Poster
Rep: Reputation: 0
Hello,

Yes, I added clamav user to the amavis group.

The "AllowSupplementaryGroups" is true and uncommented by default.

I restarted the daemons.

Now, they are working fine.


Thanks for the reply,
cviniciusm.
 
Old 07-04-2009, 04:21 AM   #4
prismasupport
LQ Newbie
 
Registered: Jul 2009
Posts: 1

Rep: Reputation: 0
Hey Bathory!

Just wanted to say thanks. This also worked for me.

"Have you done the above? You have added amavis to clamav group and not the other way around.
Also don't forget to uncomment the "AllowSupplementaryGroups" option in clamd.conf and restart both clamd and amavisd."
 
Old 09-07-2009, 04:34 PM   #5
frlarry
LQ Newbie
 
Registered: Sep 2006
Location: Mechanicsburg, Ohio
Distribution: Ubuntu 9.04
Posts: 3

Rep: Reputation: 0
Thumbs up Ditto

That's just what I was looking for, too. Thanks.
 
Old 02-01-2010, 01:35 PM   #6
jmontano
LQ Newbie
 
Registered: May 2004
Location: Colombia
Distribution: Arch Linux
Posts: 1

Rep: Reputation: 0
Thanks for your info, got it right by fixing clamav group membership
 
  


Reply

Tags
ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
clamav and amavisd-new for sendmail ragebot Slackware 2 08-16-2008 05:42 AM
postfix + amavisd + clamav + spamassassin problem leiw Linux - Server 2 03-31-2008 06:38 AM
amavisd / clamav, spamassassin problem 70mas Linux - Server 5 07-19-2007 09:42 PM
Problem with amavisd-new clamav on Fedora Core 6 ganick Linux - Server 1 04-02-2007 09:55 AM
Amavisd-new: Interface to Sendmail milter + ClamAV cyberjames Slackware 0 02-07-2005 02:41 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 01:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration