-   Linux - Server (
-   -   Perl Apache Session MySQL inconsistency on Debian Lenny (

merlininthewood 04-11-2011 08:49 AM

Perl Apache Session MySQL inconsistency on Debian Lenny

I have been tearing my hair out with this. As part of a backend perl script i am holding the Epoch time as session data using apache session and mysql so i can delete sessions after an expiry period. When I retrieve the time it is about three months old even when i only just set it. The code example below best describes the problem:

I have got the table set up that Apache session requires.


use strict;
use DBI;
use Apache::Session::MySQL;

my %config;

  $config{'dbname'} = "somedatabase";                                # Database name
  $config{'dbuser'} = "root";                        # Database user
  $config{'dbpass'} = "secret";                                # Database password
my $dbhg = DBI->connect("dbi:mysql:$config{'dbname'}",$config{"dbuser"},$config{"dbpass"})
        or die "Could not open MySQL DataBase - SQL Error: $DBI::errstr\n";
my %session;

tie %session, 'Apache::Session::MySQL', undef, {Handle=>$dbhg, LockHandle=>$dbhg};

my $sessid = $session{_session_id};

print "New session:$sessid\n";
$session{'time'} = time;

print "Time set: $session{'time'}\n";

untie %session;

#### Now to retie the session and retrieve the time

tie %session, 'Apache::Session::MySQL', $sessid, {Handle=>$dbhg, LockHandle=>$dbhg};

print "Connected session:$session{_session_id}\n";

my $retrievedTime = $session{'time'};
print "Retrieved time: $retrievedTime\n";

untie %session;

This gives the output:


New session:14199f84b1e646b528d63b3be180a9b1
Time set: 1302529444
Connected session:14199f84b1e646b528d63b3be180a9b1
Retrieved time: 1295975743

This is happening on 3 out of four machines all running Debian. It works fine on the one!?!?!

Anyone got any ideas?

mgichoga 04-11-2011 11:35 PM

Ran the same code and works for me. I'm running ubuntu 10.10 You could try add a 'undef %session' right after the first 'untie %session' so that it looks like this:


untie %session
undef %session
I don't know if this will lead to other problems with the key=>values pairings but might be a troubleshooting tool.

Also are you running the MySQL database and the perl script on the same machine? Have you checked time on local machine...probably so.


merlininthewood 04-12-2011 04:44 AM

Thanks for your reply. I tried using undef %session but with the same result. The actual script i am using this in is a mod perl script that is called on separate occasions between setting and retrieving the session data (hence the need to use apache session!!). I wrote the script above to see if it was a problem with my main script or mod perl but the phenomenon occurs on this simple perl script also. It always returns a time some time in the afternoon (but different times) on Tuesday the 25th January 2011. How weird is that?

Two of the machines it occurs on (and the one where it works OK) are running Apache::Session 1.86 and the other 1.87 (upgraded to Squeeze). The database is run on the same machine as the script in all cases.

I have googled but found no-one who has come across a similar problem.

merlininthewood 04-13-2011 02:52 PM

It gets even more weird. I started poking around inside to see where the inconsistency starts. I added some print commands to give me an idea what the values are as they are processed by apache session and it started working as it should. I narrowed it down to adding a print command in the STORE routine:

sub STORE {
    my $self  = shift;
    my $key  = shift;
    my $value = shift;
    print "VALUE=$value\n"; #####################
    $self->{data}->{$key} = $value;
    $self->{status} |= MODIFIED;
    return $self->{data}->{$key};

Now my script returns:

New session:fa8aa2bc8531313007e0463920fbd25d
Time set: 1302723468
Connected session:fa8aa2bc8531313007e0463920fbd25d
Retreived time: 1302723468

As it should. And when i remove the print statement again:

New session:92344b19524a01f524bd6afe56bbdec0
Time set: 1302723485
Connected session:92344b19524a01f524bd6afe56bbdec0
Retreived time: 1295990591

Can anyone think why printing the $value string would make it behave differently? I tried setting 'my $tmp=$value;' as an ugly fix but that didn't work.

chrism01 04-13-2011 11:45 PM

If you're really sure you've found a bug in, you can notify the maintainer; look up the module at
Also, you may want to raise this at; where all the Perl gurus hang out.

merlininthewood 04-14-2011 07:47 AM

I have raised this on if anyone wants to follow it there.

All times are GMT -5. The time now is 07:47 AM.