LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (https://www.linuxquestions.org/questions/linux-server-73/)
-   -   pecl install wont work (https://www.linuxquestions.org/questions/linux-server-73/pecl-install-wont-work-840608/)

ndani 10-26-2010 04:52 PM

pecl install wont work
 
Hello everyone!

Any ideas what can be wrong here? pecl install downloads only, and then stops, no compile and install. Same with other modules like memcache or memcached.

I've installed the necessary packages, and on another server of mine it works.
(php5-dev php-pear apache2-threaded-dev)

pecl -v doesn't give more info.

Here's what I see:
Code:

root@fokanyul:~# pecl install apc
downloading APC-3.0.19.tgz ...
Starting to download APC-3.0.19.tgz (115,735 bytes)
.........................done: 115,735 bytes
root@fokanyul:~#

Code:

root@fokanyul:~# uname -a
Linux fokanyul 2.6.32-25-generic-pae #45-Ubuntu SMP Sat Oct 16 21:01:33 UTC 2010 i686 GNU/Linux
root@fokanyul:~#

root@fokanyul:~# php -v
PHP 5.2.10-2ubuntu6 with Suhosin-Patch 0.9.7 (cli) (built: Oct 23 2009 16:30:10)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies
root@fokanyul:~#


ndani 10-28-2010 02:25 AM

I'm answering my own post:

When PHP 5.3 came out, many Drupal sites crashed, including mines.
A quick solution was to revert back to PHP 5.2, and pin this version in apt config.


Since I haven't find any solution or clue for my pecl problem yesterday, I got suspicious, and I let PHP to upgrade.

After that the pecl install process worked againg.

I don't know how this is related to each other.

The issue can be considered as solved. (Finally I must upgrade my Drupal sites...)


All times are GMT -5. The time now is 12:10 AM.