LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
LinkBack Search this Thread
Old 10-03-2012, 10:35 AM   #1
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Colombia
Distribution: Kubuntu, Debian, Knoppix
Posts: 1,957
Blog Entries: 1

Rep: Reputation: 81
pacemaker - how to start a resource


Hi!

I'm giving pacemaker a test on two ubuntu lucid virtual machines. I have already set up a virtual IP to be shared between them but I can't get the resource to start. At the moment I have heartbeat running on only one of the boxes (ha1):

Code:
$ sudo crm_mon -1
============
Last updated: Wed Oct  3 11:00:28 2012
Stack: Heartbeat
Current DC: ha1 (77ca727a-d965-410c-8829-58449dc0ef89) - partition with quorum
Version: 1.0.8-042548a451fce8400660f6031f4da6f0223dd5dd
2 Nodes configured, unknown expected votes
1 Resources configured.
============

Online: [ ha1 ]
OFFLINE: [ ha2 ]

$ sudo crm_resource --list
 virtual-ip     (ocf::heartbeat:IPaddr) Stopped
What do I have to do to get the virtual ip to come up? Thanks in advance.

Remember, it's ubuntu server 10.04.
 
Old 10-03-2012, 01:33 PM   #2
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Colombia
Distribution: Kubuntu, Debian, Knoppix
Posts: 1,957
Blog Entries: 1

Original Poster
Rep: Reputation: 81
I have still a lot of ground to cover but at least I have learned a couple of tricks.

Firs, problems in the configuration can be found with this:

Code:
crm_verify -L
That provided this output:
Code:
crm_verify[2129]: 2012/10/03_13:54:43 ERROR: unpack_resources: Resource start-up disabled since no STONITH resources have been defined
crm_verify[2129]: 2012/10/03_13:54:43 ERROR: unpack_resources: Either configure some or disable STONITH with the stonith-enabled option
crm_verify[2129]: 2012/10/03_13:54:43 ERROR: unpack_resources: NOTE: Clusters with shared data need STONITH to ensure data integrity
By reading from http://www.clusterlabs.org/doc/en-US...atch/ch05.html I found that stonith can be disabled with this:
Code:
crm configure property stonith-enabled=false
 
  


Reply

Tags
heartbeat, lucid, pacemaker, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] linux ha: Illegal directive [pacemaker] in ha.cf eantoranz Linux - Server 1 10-02-2012 04:31 PM
pacemaker with drbd and lvm anilcliff Linux - Server 0 07-13-2012 12:53 PM
[SOLVED] DRBD + Pacemaker Problem hesisaboury Linux - Server 2 06-05-2012 07:48 AM
Heartbeat cluster won't recognize other node, resource won't start. slinx Linux - Enterprise 2 04-08-2010 10:48 PM
Heartbeat cluster won't recognize other node, resource won't start. slinx Linux - Enterprise 1 03-31-2010 11:19 AM


All times are GMT -5. The time now is 12:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration